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IntroductIon
You’ve no doubt browsed hundreds, if not thou-
sands, of web pages in your life, but have you 
ever had a chance to peek behind the scenes and 
see how web pages come to look and behave the 
way they do?

As an educational technologist you’ll almost cer-
tainly need to design and sometimes build web 
pages yourself. This tutorial will help you acquire 
the skills and knowledge you need to create a 
web page and, eventually, an entire web site.

At the same time, the templates you’ll use will 
help you acquire good basic page layout and 
typographic design skills, to go along with the 
design skills you’re learning in this course.
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Introduction

How to use this tutorial
The first time you go through this tutorial, you 
can start at the beginning and more or less pro-
ceed through the chapters—or sessions—in order. 
Each chapter is keyed to a segment of the course.

From session 2 on you’ll be working with a tem-
plate for your professional portfolio. In each ses-
sion you’ll make a number of modifications to the 
original template, so that by the time you reach 
the end of the book, you will have transformed 
the generic template into a personal, professional 
e-portfolio.

When you begin working on your own projects, 
you can use this book as a reference. Use the table 
of contents and the index to find the specific task 
you’re trying to accomplish, and review how you 
did it in Homer. Then apply the same or similar 
strategies in your new work.

While this tutorial assumes you are working with 
our template, most of the techniques will work 
with any web page.

¸	Tip

n	File management is the most crucial prerequi-
site knowledge to successful use of this tuto-
rial, since you’ll need to be constantly backing 
up files, renaming them, moving them from 
place to place, and so forth. If you’re prone 
to misplacing or altogether losing files, or are 
otherwise confused about how your comput-
er’s operating system works, take some time 
now—before frustration sets in—to get a firm 
handle on file management.  
 
Take a class, go through a tutorial, ask a friend 
for a one-on-one lesson, but get comfortable 
with saving, locating, retrieving, moving, 
renaming, backing up, transferring, and delet-
ing files. Understand the relationships among 
applications, files, and folders. It’ll make life 
so, so much easier in the next few weeks.
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SImple Html
In this first session, you’ll meet some web page 
authoring software (Macromedia Dreamweaver) 
and try your hand at creating a simple web page. 
This session will also serve as a brief introduction 
to the language of web pages—the hyptertext 
markup language (HTML).

In the following sessions you’ll learn to use pre-
designed templates to create more elaborate web 
sites. You’ll populate your web site with video 
and animation, and learn to post it all on a web 
server for the world to gaze on in wonder!
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Organizing your files
File management… you’ll hear us rant and rave 
about this constantly, because without under-
standing how your folders and files are orga-
nized, you’ll become frustrated very quickly.

If you’re a little hazy about file management—
how to find files, create new files, delete old files, 
rename files, duplicate files, download and unzip 
files, and move files around in your computer’s 
operating system, now’s the time to master that 
before continuing!

Got it? The folders we’re going to be working 
with today are on your course web site.

�. Download and upzip the edtec541 folder. It 
should look something like Figure 1.1.

Be sure you actually unzip the package you 
download (Mac users, double-click; Win users, 
right-click and choose Extract All…). Windows 
will let you see and even open files inside a 
zipped package, but you don’t want to do that!

The unzipped edtec541 folder contains two 
folders, myweb and offline. Study the hierarchi-
cal file organization so you’ll know where to find 
these on your computer. 

For example, notice that the myweb folder con-
tains the assign folder and the portfolio folder. 
Visually, that looks like Figure 1.1.

The “path name” for the assign folder (assuming 
it is on your desktop) would be something like 
Desktop/edtec541/myweb/assign/.

Like little Russian dolls, one inside the other. 
That’s how everything on your computer—Mac 
or Win—is organized, strictly hierarchically. 
Really understand that and you’ll be a happier, 
healthier person in the weeks to come.

Figure �.� Here’s what the unzipped edtec 541 folder 
should look like in the Mac Finder, if  you select the 
View > As List menu item (we recommend this or View 
> As Columns for efficient file management). It will 
look about the same in Win if  you select the View > 
Explorer Bar > Folders menu item). 
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Macromedia Dreamweaver
If this is the first time you’ve used Dreamweaver, 
let’s take a minute to look around.

�. Download and install Macromedia 
Dreamweaver, if needed.

Important note: At this writing (May, 2006), 
Adobe has purchased and is gradually swallow-
ing Macromedia, but they haven’t yet changed 
the name of Macromedia’s software packages. By 
the time you read this, who knows?

�. Open Dreamweaver and in the Start Page 
select Create New > HTML (Figure 1.2).

Look for:

• The document window with three tabs for the 
Code, Split, and Design views. Select the De-
sign view if necessary (Figure 1.3).

• The Properties panel (usually beneath the 
document window, but you can move it any-
where on the screen you wish (Figure 1.3).

• An assortment of information and editing 
panels on the right side (hide or show different 
ones using the Windows menu).

�. Select the File > Save menu item, name 
this file ments.htm and save it inside the 
assign folder (which you’ll find inside your 
edtec541/myweb folder—see Figure 1.4).

Get it? assign/ments? Cute, huh?

All right, all right. Move on and we’ll type some-
thing into this blank page.

Figure �.� The Dreamweaver Start Page.

Figure �.� Your new, unsaved, untitled document will 
look something like this in Dreamweaver.

Figure �.� The Save As dialog box.
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Editing a web page
In some ways, making a web page is just like 
word processing, only different.

First, let’s give the page a title.

�. In the Title field at the top of the main docu-
ment window, type your last name, comma, 
first name (Figure 1.5).

This Title is the label that will appear in the Title 
Bar at the top of your page in the web browser.

�. In the main document space, type a heading 
at the top of the page, and press the RETURN 
key (Figure 1.6).

Use something creative, like, “Jane Doe’s EDTEC 
541 Assignments.” But please use your own 
name, of course (if you want credit for your as-
signments).

�. Type the list of assignments in the Design 
view using a carriage RETURN at the end of 
each line (Figure 1.6).

Figure �.� The Title field at the top of  the document 
window.

Figure �.� Type a heading and the list of  your assign-
ments into the body of  the document.



�

Simple HTML

Formatting web page text
You can format text in a web page in Dreamweaver 
much as you would format text in a word proces-
sor. However…

Important note: Do not use the Font, Size, and 
Color fields in the Properties panel. Soon we’ll 
be using Cascading Style Sheets (CSS) to style our 
pages, and using these three fields in the Proper-
ties panel will interfere with the CSS.

Headings

�. Click and drag across the first line of text to 
select it (Figure 1.7).

�. Select Heading � from the Format pop-up 
menu in the Properties panel (Figure 1.7).

Links

�. Select the second line of text (Figure 1.8).

�. Type journal.htm in the Link field in the 
Properties panel (Figure 1.8).

You haven’t created the web page named 
journal.htm yet, but you can still link to it in 
anticipation by just typing in the path name. Each 
of these assignments will be linked to a different 
page, but we’ll leave the rest for later.

Bullets

�. Select the entire list of assignments (following 
the heading).

�. Click on the  (Unordered List) button 
(Figure 1.9).

Figure �.� Designating a heading using the Format 
pop-up menu in the Properties panel.

Figure �.8 Creating a link using the Link field in the 
Properties panel.

Figure �.9 Making a bulleted list using the Unordered 
List button in the Properties panel.
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Figure �.�0 Your assignment page will look something 
like this in a web browser.

Previewing your work
We won’t be uploading this page to the Internet 
just yet, but you can see how it will look in a web 
browser right away.

�. Click on the  (Preview/Debug in Brows-
er) button and select a browser from the pop-
up menu.

Your page should look about like Figure 1.10.

If you don’t have any browsers listed in the 
Preview/Debug in Browser pop-up menu, add 
some by clicking on the Edit Browser List… 
menu item and following directions. 
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Viewing and editing HTML
So far we’ve been using Dreamweaver like a 
WYSIWYG (what-you-see-is-what-you-get) word 
processor in the Design view.

To see (and change) what makes a web page tick, 
let’s look at the HTML Code view.

Switching to Code view

�. Click on the Code view tab at the top of the 
document window (Figure 1.11).

Things to notice in Code view

• HTML tags are always between less-than (<) 
and greater-than (>) symbols.

• Most HTML tags are used in pairs, for exam-
ple, find the opening and closing head tags:

<head>... </head>

• HTML tags apply to anything between the 
opening and closing parts of the tag. For exam-
ple, everything you want to display in the web 
browser must go in the body tag:

<body> [your content] </body>

Things to do in Code view

You can edit in the Code view just as you do in 
the Design view.

• You can type text. For example, after the “Final 
Project” line, enter a carriage return and type 
new text, such as “Another Project.”

• You can type HTML tags. For example, before 
and after the line you just typed, insert “list” 
tags like this:

<li>Another Project</li>

Return to Design view to see how this looks.

Figure �.�� The HTML behind the page.
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Figure �.�� How many of  the HTML tags at the left can 
you find in your first web page?

Common HTML tags
There are dozens of HTML tags that let web 
authors define how their pages will look in web 
browsers. 

You can find the complete list at the World Wide 
Web Consortium (W3C) web site, but for now, 
here are some useful ones to recognize. See how 
many you can find in the ments.htm page you 
just made in Dreamweaver.

<html>… </html> tells the browser that ev-
erything between these tags should be inter-
preted as HTML code.

<head>… </head> encloses information 
about the page, like the page title.

<title>… </title> displays the page title in 
the title bar of the browser window.

<body>… </body> encloses everything that 
displays in the browser window.

<p>… </p> brackets a paragraph.

<h1>… </h1> indicates a level 1 heading.

<ul>… </ul> a bulleted (unordered) list

<ol>… </ol> a numbered (ordered) list

<li>… </li> each line in any list

<a>… </a> an anchor link to another loca-
tion on the current page, or to another page 
(see an example on line 11 of Figure 1.12)

<img> (no end tag) inserts an image

<b>… </b> bold text

<em>… </em> italic (emphasized) text

To learn more about HTML and other web page 
languages, visit the free W3C on line schools:

http://www.w3schools.com/

Hand Coding

When the web first came on the scene, 
the only way to format web pages was to 
write HTML tags by hand. These days, 
however, WYSIWYG web page editors like 
Dreamweaver make hand coding unneccesary, 
for the most part.

Nevertheless, it’s a good idea to understand 
a little about HTML, because sometimes 
the WYSIWYG editors don’t get everything 
quite right. At times like those, it’s handy 
to be able to go into the HTML code and 
straighten things out by hand.

That’s what Dreamweaver’s Code view is for, 
and why we’ve taken the time to draw your 
attention to basic HTML tags and structure.
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template to Go
In this section you will use Macromedia 
Dreamweaver and a web page template to begin 
building your own professional e-portfolio. You 
can use this portfolio in at least two ways. 

First, you’ll use this portfolio to collect, docu-
ment, and reflect on the work you do in the SDSU 
Educational Technology program. You will popu-
late it with samples of projects, products, reports, 
academic papers, and anything else you  do in 
your courses. You’ll use that collection to demon-
strate your accomplishments to the faculty, espe-
cially towards the end of your program.

Second, you may also use this portfolio, perhaps 
revised a little, for demonstrating your skills and 
knowledge to prospective employers.

In the process of putting together your e-port-
folio, you’ll learn the basics of web page layout, 
navigation design, and web site development. By 
the time you’ve finished this project, you’ll not 
only have the essentials of your own professional 
portfolio, you’ll also have acquired the design 
and development skills needed to create your 
own web projects of any kind.
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Why use a template?
It used to be that anyone, with some rudimentary 
knowledge and skill, could put together a satis-
factory web page from scratch, using a plain text 
editor or, later, a WYSIWYG editor. Laying out 
pages, building a navigation system, and posting 
your site on a web server were not much more 
complex than using a full-featured word proces-
sor, as you discovered in the previous session.

In the last few years, however, web technology 
has become increasingly complex. We’ve seen the 
emergence of standards to ensure accessibility 
for users with disabilities. We’ve witnessed the 
advent of cascading style sheets, providing far 
greater control and flexibility for web pages and 
web sites. We’ve seen Javascript and database 
interactivity, and many other technologies that 
bring wonderful new features but also require 
more and more sophisticated development skills.

That’s not to say that you still can’t create a de-
cent web page from scratch. But if you want an 
accessible site with powerful features, you’ll need 
a level of technical skill that comes only from 
many months of diligent practice—or you’ll need 
a template.

Starting with a good template can help you not 
only with the technical issues, but with usability 
and aesthetics as well. Working with this and 
other templates is a wonderful way to gain the 
experience you need to become a respectable 
designer and a fluent web developer.

What template to use?

There are good templates and… not so good 
templates, of course. Ones that help provide 
accessibility, usability, and look good, and… 
the others.

For this project, you’ll use a template that 
we provide, that we know to be reasonably 
accessible, pretty usable, and not horrible to 
look at.

Modifying this template to suit your needs 
while maintaining accessibility, usability, and 
aesthetics will help you use these criteria 
when you choose a template for your next 
project.
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Locating the template
In the previous session you downloaded and 
unzipped the edtec541 folder to your Windows 
or Macintosh computer.

Inside it you’ll find the myweb folder and inside 
that a folder named portfolio that contains sever-
al files and sub-folders, and that looks something 
like Figure 2.1.

Figure �.� Contents of  the portfolio folder  shown in 
the “List” view on Macintosh OS X. The look is a little 
different but the structure is the same in Windows Ex-
plorer. (Note: some file names may differ.)
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Defining your site in 
Macromedia Dreamweaver
Before you begin opening, inspecting, and modi-
fying web pages, it’s very important to define 
the web site—the folder that contains your web 
pages—in Dreamweaver.

This allows Dreamweaver to provide a dedicated 
“desktop” for your site—the Files window—
which automates many file management tasks. 
For example, when you rename or move a file 
in Dreamweaver’s Files window, Dreamweaver 
can update all files within the site that link to or 
refer to that page.

To define your site:

�. Select the Site > Manage Sites… menu item, 
and in the Manage Sites dialog box click on 
the New… button and select Site.

�. In the Site Definition dialog box, click on the 
Advanced tab and fill in the Site name field 
as in Figure 2.2. Use your name of course!

�. Use the folder icon to the right of the Local 
root folder field to browse to your portfolio 
folder (wherever you have placed it on your 
computer’s hard disk or removable storage).

�. With portfolio selected in the Choose local 
root folder dialog box, click Choose.

�. Click OK in the Site Definition dialog and 
Done in the Manage Sites dialog. If prompt-
ed, let Dreamweaver create a site cache.

¸	Tips

n	The site definition in Dreamweaver is as-
sociated with your computer, not with the 
site itself. So on your own computer, you’ll 
only need to define a site once. Every time 
you open Dreamweaver on that computer, 
that site will be available. But when you go 
to work on your site on a different comput-
er—say, in a computer lab or in another of-
fice—you’ll need to define your site again, in 
that copy of Dreamweaver.

n	Be sure to remove the site definition when 
you’re finished working on a public comput-
er, as in a school computer lab or classroom. 
If you don’t remove the definition, anyone 
who opens Dreamweaver will have instant 
access to your web server account. They could 
accidently or purposefully upload new and 
“interesting” things to your account—things 
Homeland Security might frown on! See “Re-
moving a Dreamweaver site from your list of 
sites” in Dreamweaver Help.

Figure �.� Dreamweaver’s Site Definition dialog box. The Site name can be anything that will remind you of  what 
this site is. It won’t actually appear anywhere on your Web site.



��

Session 2

Opening, viewing, and 
previewing web pages 
Dreamweaver and other WYSIWYG web page 
editors will open any HTML file.

To open a web page in Dreamweaver:

�. If the Files window is not currently visible 
in Dreamweaver, select the Window > Files 
menu item.

�. In the Local panel of the Files window, dou-
ble-click on index.htm or any file you wish to 
open).

To select page viewing modes:

�. Click on the  (Show Design view) 
button to view or edit the open page in WYSI-
WYG mode (Figure 1.3).

�. Click on the  (Show Code view) 
button to inspect or edit the HTML and other 
code behind the web page (Figure 1.4).

�. Click on the Show Split view button to dis-
play both HTML and WYSIWYG simultane-
ously, one above the other (Figure 1.5).

To preview a web page in a browser:

�. With your web page open in Dreamweaver, 

select the  (Preview/Debug in browser) 
pop-up menu.

�. Select a browser from the list (if no browsers 
are listed, select Edit Browser List…)

Figure �.� Design view of  index.htm.

Figure �.� Code view of  index.htm.
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Figure �.� Split view of  index.htm.

Does Design view show all?

Notice that the navigation menu (left side 
of the page, below the word “Jane”) doesn’t 
appear in the Design view (Figure 2.3) in 
Dreamweaver, but suddenly shows up when 
you preview it in a browser (Figure 2.6).

In this template, the menu is supplied using 
Javascript—a kind of add-on to HTML—and 
Dreamweaver doesn’t preview it in the De-
sign view. That’s one reason it’s important to 
frequently—constantly—preview your page 
in at least one web browser as you work.

Figure �.� The index.htm page in a browser.

¸	Tip

n	Important: Try to restrain yourself from edit-
ing anything in the template until and un-
less you receive instructions in this tutorial 
or elsewhere. Editing the wrong part—or the 
right part in the wrong way—could result in 
“breaking” the template to the extent that you 
might need to start over in order to repair the 
damage.  
 
Don’t worry, we’ll get to everything in due 
time! We’ll be editing the styles, the menus, 
the colors, the images, the text, the page lay-
out… everything!
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Understanding page layout
One reason we’re using a ready-made template 
for our first web page is so that we can put off 
facing one of the thorniest issues, page layout. 
We’ll learn how to control page layout later, 
but for now, let’s just try to identify the differ-
ent parts of the page and see how they all work 
together.

First, with the local copy of your portfolio site 
open in Dreamweaver, open index.htm and look 
at the page in Design view (Figure 2.3).

Observe the graphic banner across the top, the 
navigation bar (sans menu in the Design view, 
as we noted earlier) at left, and the main content 
area that takes up most of the rest of the page.

Each of these areas—top, left, and content—are 
separate HTML layers. A layout layer—called 
a “div” (for “division”)—is just a rectangular 
container you can put things in, and position on 
a page. Figure 2.7 is a diagram of the three main 
divs that make up this page.

The top div contains a graphic banner with a 
background and the words “Jane Doe” in them. 
The left layer starts underneath the top layer and 
contains only a blank graphic background. The 
Content layer contains a graphic background (the 
little rounded corner in the upper left), a picture 
of Jane Doe, and the text of the Welcome section.

Other layers

Scroll down a bit in the Design view of 
index.htm and you’ll see an outline of the 
menu structure. That’s what Javascript will 
use to build the menu you see when you pre-
view the page in your browser (Figure 2.6). 
We’ll get into the details of how that works 
later. For now, just know that’s a layout div, 
too, but one that will be repositioned and 
reformated when it reaches a web browser.

There’s also a layer at the top right with the 
page title, and one at the lower right with 
the date the page was last updated. More on 
both of these divs later.

Figure �.� Basic layout of  Jane Doe’s index.htm page.

Using Tables for Layout

For many years, we all used data tables for 
page layout. It works OK, but isn’t as flexible 
and accessible as using layout divs, which 
are made for the purpose.
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Viewing layout divs
One of the trickiest things about working with 
layout divs is that, normally, they’re invisible. It 
would be nice if you could see them while you 
were working on your document. Dreamweaver 
makes that easier with a couple of nice features.

To view layout divs:

�. Still in the Design view, select the View > 
Visual Aids… > CSS Layout Backgrounds 
menu item. Each div is displayed in a differ-
ent, arbitrary color (Figure 2.8).

�. Examine what that looks like, and compare it 
with the diagram in Figure 2.7, then turn it off 
by deselecting the View > Visual Aids… > 
CSS Layout Backgrounds menu item.

�. Be sure the View > Visual Aids… > CSS 
Layout Box Model menu item is checked.

�. Insert your cursor anywhere in the text in the 
main Content div.

�. Select the <div#content> tag button in the 
status bar at the bottom of the Design win-
dow. This selects the Content div and, with 
the Box Model visual aid turned on, you 
can see not only the outlines of the div, but 
cross-hatching indicating the div margins 
(Figure 2.9).

�. Try selecting each of the main divs in turn, 
and see how they correspond with the dia-
gram (Figure 2.7).

Figure �.8 The index.htm page in Design view with CSS 
Layout Backgrounds highlighted in arbitrary colors 
(if  printed on a B&W printer, this image will just show 
shades of  grey).

¸	Tip

n	With the CSS Layout Backgrounds menu 
item checked, each div (Figure 2.8) is dis-
played in a different, arbitrary color. Some, 
like the left div and part of the top div, don’t 
seem to be highlighted, because they contain 
images that mask the highlight colors.

Figure �.9 The index.htm page in Design view with CSS 
Layout Box Model and Layer Outlines turned on.
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Figure �.�0 A good place to store the backups of  your 
portfolio folder, such as portfolio_01 in this case, is in 
the offline folder.

Backing up your portfolio
Before we begin customizing and making chang-
es to the portfolio template, it’s a good idea to 
make a backup copy. In fact, it’s important to 
make backup copies at regular intervals as you 
progress. They don’t take up much space, and 
they could potentially save you hours and hours 
of work if you make an unrecoverable mistake 
(and you’re likely to do that once in a while, no 
matter how experienced you become).

To duplicate a folder in Windows:

�. In Windows Explorer, select the folder you 
wish to duplicate (in our example, portfolio).

�. Right click on the  folder and select the Copy 
menu item from the pop-up menu.

�. Navigate in Explorer to a different folder 
where you want to keep the backup.

�. Right click and select the Paste menu item.

�. Click once on the new folder name (by default 
it will include the old folder name) and type 
the new name.

To duplicate a folder in Macintosh:

�. In Macintosh Finder, select the folder you 
wish to duplicate.

�. Control-click on the  folder and select the Du-
plicate menu item from the pop-up menu.

�. Move the folder to a different folder where 
you want to keep the backup.

�. Click once on the new folder name (by default 
the name will be the same name as the origi-
nal with the word “copy” appended) and type 
the new name.

¸	Tips

n	Always duplicate your portfolio folder on 
your system (Windows Explorer or Macintosh 
Finder), not in Dreamweaver.

n	A good place to keep your portfolio backups 
is in the offline folder. We recommend a sim-
ple numbering system, such as portfolio_01, 
portfolio_02, and so on.

n	When you’ve built up a number of backup 
folders, you can delete some of the earlier 
ones if you’re confident you won’t need them 
any more.
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Customizing the template
We want to get more deeply into the inner work-
ings of web pages, but first let’s see just how easy 
it is to make this template your own.

To enter text:

�. In Dreamweaver’s Files widow (Local side), 
open the index.htm file (or any file in which 
you wish to edit text).

�. Click in the Content div (or other div you 
wish to change).

�. Cut, copy, paste, and/or type new text into 
this area. Use the Edit menu or keyboard 
equivalents for Cut, Copy, and Paste.

�. Be sure to preserve the last line in the Content 
div (“Check page accessibility…”) so you can 
easily test your page as you continue revising 
and developing it. If you accidently delete it, 
don’t worry, you have a backup from which 
to retrieve it. (Don’t you?)

Figure �.�� Begin drafting your “home” page text.

What to write in your portfolio

Here are some ideas for what you might in-
clude on your portfolio Welcome page:

• The purpose of the portfolio (to share 
information; to find a job; to demonstrate 
skills and knowledge; or the like).

• Your “mission” (to educate, to learn, to 
save the world, blah blah blah…).

• Who you are (your professional labels, 
your background, your experience, your 
strengths, etc.)

For one intriguing approach, see Reshma 
Kotwal’s story (at left) for the Welcome page 
of her portfolio.

Reshma Kotwal’s story

Imagine a retired math professor half-blind-
ed by glaucoma teaching a young girl the 
complex principles of solid geometry.

He encourages her to look beyond the ab-
stract formulae and visualize the shapes in 
her mind’s eye. He helps her to decipher 
cubes, cones, and spheres—shapes that 
are just blurred outlines for him—from the 
clutter of geometric objects that crowd our 
world. Amazed, the student wonders how 
he stimulates her visual-thinking skills when 
he can barely see.

It was a memorable teaching-learning ex-
perience, and it has stayed with me to this 
day. Professor Gai was a brilliant teacher 
who transformed the lives of his pupils with 
his engaging teaching methods. In the same 
way, I aspire to create learning environments 
that will transform the lives of adults.

As an instructional designer, I am excited by 
the potential of information technology (IT) 
to create real-world, collaborative learning 
environments and aim to explore the evolv-
ing role of IT in enabling learning. 
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The HTML from �0,000 feet
From time to time we’ll be using the Code view 
to go in and tweak or fix bits of HTML directly, 
since the Design view doesn’t show everything 
and doesn’t provide as much control as you oc-
casionally need.

So it’s always a good idea to look over the code 
and at least identify where the “big chunks” 
are so you can zoom in on details quickly when 
needed.

On the next page (Figure 2.13) is the Code view 
of index.htm as it looks now. The text in the Con-
tent div will be your own instead of Jane’s, but 
the rest should be the same.

Study Figure 2.13 and your own Code view, and 
compare the labeled sections with the way the 
page displays in a web browser (Figure 2.12).

It’s a little more complex than that first, simple 
web page you created in the previous section, 
but it is structured basically the same (head and 
body) and uses many of the same tags (para-
graph, heading, and so on).

Figure �.�� Web browser view of  index.htm.
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Figure �.�� Code view of  index.htm.

Top div, with the titlePage div 
embedded in it.

Head section, with document info, metatags, 
title tag, and Javascript for menus.

Left div, with only an image.

Body section, starting with 
more menu Javascript.

Content div, with Jane’s 
portrait and  body copy.

Accessibility test button.

Footer with automatic “last updated” date.

Menu content in the form of  
a “library” item that is shared 
with other pages in the site.
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Starting a new page
The portfolio template comes with several starter 
pages just to show some of the different things 
you can do. But you’ll need several pages in ad-
dition to those, and now is a good time to begin 
building them.

For example, you’ll probably want a biography 
page to give folks a little background on how you 
got to where you are today.

To create a new page:

�. In Dreamweaver’s Local Files panel, right-
click (Win) or control-click (Mac) on an exist-
ing file, such as index.htm, and select Edit… 
> Duplicate from the pop-up menu.

�. Click once on the name of the new file (de-
fault name will be Copy of  index.htm) and 
type the new name for the file: bio.htm.

�. Double-click on the new file to open and edit 
the contents.

�. Select the “Welcome” heading in the Content 
div, and type “Biography”.

�. Select the rest of the text (except the last line 
with the accessibility button) and type (or 
paste) your biography.

�. Save and preview the new page in your web 
browser.

Who am I?

When you’re deciding what to include in 
your biography, be sure to identify your 
audience first and then put yourself in their 
shoes. Who are they (prospective employers, 
professors, family members, friends)? Then 
include things of interest to that audience.

For example, you probably wouldn’t say 
much about your early childhood if this is 
aimed at prospective employers and/or 
faculty. Instead, you’ll want to spend most of 
your space regaling them with background 
about how you moved from one position to 
another as you developed during and after 
college.

¸	Tip

n	When you first create a new file, it will most 
likely appear at the bottom of the list within 

the folder. Click the  (Refresh) button in 
the Files window to reorder the list.
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Pretty handsome…
Your new e-portfolio already looks pretty spiff-
ing, and you’ve only begun! In the next session, 
you’ll post your handiwork on the World Wide 
Web, and begin to get a handle on Cascading 
Style Sheets (CSS) used to control page layout, 
type design, and more.
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Defining a new local site
In Homer Session 2 you defined your portfolio 
web site in Dreamweaver. You can define as many 
local sites as you wish, and, indeed, you’re going 
to need several for this tutorial.

Let’s define two new local sites, one with the 
myweb folder, and another for the assign folder.

Note: Follow this procedure twice, once for each 
of those folders.

To define a new site:

�. Select the Site > Manage Sites… menu item, 
and in the Manage Sites dialog box click on 
the New… button and select Site.

�. In the Site Definition dialog box, click on the 
Advanced tab and fill in the Site name field.

The first time you follow this procedure, name it 
“My Web.” The second time you follow the pro-
cedure, name it “Assignments.”

�. Use the folder icon to the right of the Local 
root folder field to select the appropriate root 
folder.

The first time through, browse to your myweb 
folder. The second time, select your assign folder.

�. Click OK in the Site Definition dialog. 

If you receive a warning message to the effect 
that “The root folder you have chosen is inside” 
some other folder, click OK to dismiss the mes-
sage and continue.

�. Click Done in the Manage Sites dialog. 

After following this procedure twice, the Show 
pop-up menu in Dreamweaver’s Files panel 
should display all three of your site definitions, 
including your original portfolio site. 

¸	Tip

n	To switch between site definitions, use the 
Show pop-up menu in Dreamweaver’s Files 
panel.
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Defining the remote site
Before you can upload your new web pages to 
your web account, you must tell Dreamweaver 
where it is. 

You now have at least three local sites defined, 
so we’ll need to connect each one with the corre-
sponding remote folder in your web account. 

Let’s start with your My Web site, because that 
will contain your other folders (assign and 
portfolio).

To define a remote site:

�. Select your “My Web” site from the Show 
pop-up menu in Dreamweaver’s Files panel.

�. Select the Manage Sites… menu item from 
the same Show pop-up menu.

�. In the Manage Sites dialog, click on the 
Edit… button.

�. In the Advanced tab of the Site Definition 
dialog, click on Remote Info in the Category 
list.

�. Select FTP in the Access pop-up menu.

�. Enter the appropriate domain name in the 
FTP host field (check your Internet Service 
Provider’s instructions for the correct domain 
name for FTP-ing web pages).

�. Enter the Host directory, if there is one (see 
your ISP’s instructions).

8. Enter your Login (username) and Password 
for this account in the appropriate fields.

9. Click the Test button to check your account 
information.

�0. Select the check boxes at the bottom of the 
dialog as shown in Figure 3.1, and fill in your 

What’s a Host directory?

If you’re working at the highest or “root” 
level of your web account, sometimes there 
is no need to specify a Host directory. Follow 
your ISP’s instructions in this regard.

Soon, when you’re working with sub-fold-
ers like assign and portfolio, you need to 
specify the appropriate sub-directory (Host 
directory). More on this when we define the 
remote side of those sites.

Figure �.� A completed Remote Info dialog box for an 
account on the SDSU rohan web server.
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Check out name and Email address.

��. Click on OK.

��. In the Manage Sites dialog, click on Done.

Check in and check out

Check in and check out helps keep you 
from overwriting changes you make to your 
web site from different computers, such as 
your home computer and your office or lab 
computer. It also helps when two or more 
individuals are collaborating on a single site.
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Checking your Site Definition
Before you begin uploading or downloading files, 
it is vital to carefully check your site definition. 
If you get it wrong at this stage, you’ll get copies 
of your files in unexpected places, and you’ll be 
confused in no time at all. Apply everything you 
know about file management.

Here’s what you’re looking for: The highest—or 
“root”—level of your Remote Info must match 
the root level of your Local Info. Must. Check 
with your instructor if you’re not sure you have it 
just right.

To check your Site Definition:

�. Click on the  (Expand to show local and 
remote sites) button.

�. Hover your mouse over the top folder on the 
Local Files side of the expanded Files win-
dow (Figure 3.2).

�. Inspect the path name of the top folder, and 
especially the name of the top folder itself.

�. Click on the  (Connects to remote host) 
button on the Remote Files side of the Files 
window.

�. Hover your mouse over the top folder on the 
Remote Files side of the Files window and 
check to see that the name of the top folder is 
exactly parallel to the top folder on the Local 
Files side. The names won’t be the same, but the 
folders should be parallel in their relative posi-
tions in the file hierarchy (see What is parallel?).

Figure �.� With your mouse hovering over the top fold-
er on the Local Files side of  the Files window, check to 
see that it (the top folder) represents the same level in 
the file hierarchy as the top folder on the Remote side.

What is parallel?

If you’ve been following the example in this 
tutorial, the Remote root folder will be your 
public_html folder on SDSU’s rohan, while 
the Local root folder will be myweb.

If your ISP does not specify a host directory, 
it is probably using your Login for that pur-
pose. In that case, you don’t put anything in 
the Host directory field in the Site Defini-
tion dialog.

Confusing at first, ain’t it?
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Uploading files to a web 
server
With both the Local and Remote root fold-
ers correctly designated in the Site Definition, 
you’re ready to upload or download files.

To upload a file or folder to your web 
account:

�. Select the appropriate site definition in the 
Show pop-up menu in the Files panel.

If you’ve been following our example, select the 
“My Web” site.

�. On the Local Files side of the Files window, 
select the file or folder you wish to upload.

In our example, you’ll want to select both the 
portfolio and assign folders.

�. Click on the  (Check in) button.

�. If asked whether you want to check in “de-
pendent files,” click No.

What are dependent files?

Dependent files are images or other media 
files that are embedded in an HTML file. 
When you check in an HTML file with de-
pendent files, Dreamweaver will ask whether 
you want to check the dependent files in at 
the same time.

Unless you’ve made changes to the depen-
dent files, there’s no need to do that, and it 
just takes extra time to re-copy those (usu-
ally larger) files back and forth every time 
you upload or download a (usually smaller) 
HTML page.

Figure �.� The Files window showing both the Remote 
Files (left) and Local Files (right) after uploading the 
portfolio and assign folders to the web server.

Verifying your Site Definition

This is a good time to again check the cor-
rectness of your Site Definition. It’s a little 
easier now, since you can see the file struc-
ture on both the local and remote (server) 
sides of the site (Figure 3.3).

Simply compare the indenting of the fold-
ers and files on either side of the Files 
window. They should be same. Notice, for 
example, that the portfolio folder is indented 
one level from the top folder on both sides 
(Figure 3.3).

¸	Tip

n	The key here is to keep the file structure on 
the Remote and Local (server) sides of the File 
window identical. If you move or rename a 
file on either side, be sure to update the other 
side as well.
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Defining other remote sites
Remember, we defined three local sites, but only 
one of them is connected to it’s corresponding 
remote site, so far. Let’s connect the others.

Follow this procedure twice, once for your “As-
signments” site definition, and once for your 
“Portfolio” definition.

To define the remote side of sites:

�. Select the site you wish to define from the 
Show pop-up menu in Dreamweaver’s Files 
panel.

In turn, we’ll select the “Assignments” and “Port-
folio” sites.

�. Follow previous instructions for editing the 
remote site, selecting the FTP option, and en-
tering your FTP host, Login (username) and 
Password in the appropriate fields.

�. Enter the Host directory.

In our examples, the Host directory would be:

public_html/assign/

public_html/portfolio/

For ISPs that don’t use a top level Host direc-
tory, the Host directory field would be:

assign/

portfolio/

�. Click the Test button to check your account 
information.

�. Set up check in and check out as before.

�. Click OK and Done.

�. Check each site in the Files window (see 
Figures 3.4 and 3.5)

Figure �.� The “Assignments” site after defining the 
remote side.

Figure �.� The “Portfolio” site after defining the remote 
side.
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Downloading files from a web 
server
When you want to edit a file that is already on 
your web server, you must download it to your 
local computer, do the editing there, and then up-
load it again to the server. Downloading is pretty 
much a mirror of uploading.

To download a file from your web 
account:

�. If necessary, select the appropriate site from 
the Show pop-up menu in the Files panel.

From here on out, you’ll be doing all your work 
in this tutorial in the “Portfolio” site.

�. Select the file or folder you wish to download 
on the Remote Files (server) side of the Files 
window. (Figure 3.6).

�. Click the  (Check out) button.

�. If asked about “dependent files,” click No. 
(Figure 3.7).

¸	Tip

n	You can also upload and download files by 
dragging them back and forth from one side 
to the other. This is risky, however, because 
it doesn’t guarantee the file structure will be 
preserved. Using Check in and Check out 
buttons helps keep your files in the right place 
(as long as you’ve defined your site properly).

Figure �.� Usually—though not always—you do not 
want to check out dependent files. See What are depen-
dent files?

Why are my files locked?

Notice that when you check in a file, it be-
comes “locked” in the Local Files side of 
the Files window. When you check it out, 
it is “unlocked” and gets a little check mark 
beside it. What’s happening?

The lock indicates that the file is “checked 
in.” In order to edit it, you need to “check it 
out” from the server. The little check mark 
indicates to you—or anyone else who might 
want to edit that same file from a different 
local computer—that someone else is already 
editing it, and to leave it alone for the time 
being, until it is checked back in.

Figure �.� The index.htm file checked out from the 
Remote Files side of  the Files window.
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Checking files on the web
Once your files are uploaded to a web server, you 
(and everyone else) should be able to access them 
from the Internet using a web browser.

To browse your web pages:

�. In an open web browser, type the URL to your 
new web page in the location field and press 
the return or enter key.

The URL starts with http:// followed by the 
path name to your file on the server. Check your 
internet service provider’s instructions for de-
termining the server or domain name to use 
(Figure 4.6).

Which browser?

There are several popular browsers out there 
on both Mac and Win platforms. We recom-
mend Firefox on both platforms, as conform-
ing best to HTML and other standards.

Nevertheless, if you want your pages to look 
reasonably good on as many browsers and 
platforms as possible, the only way to know 
for sure is to test them in those environ-
ments.

Most browsers are free, so we recommend 
downloading Internet Explorer and any other 
browsers you think your users may have. 
Add them to the browser list in Dreamweaver 
and test your pages with them regularly.

Figure �.� The URL to the first page (index.htm) of  Jane Doe’s port-
folio on the rohan server. On this server, all URLs include a tilda (~) 
before the username as part of  the URL.
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Removing a site definition
If you’re using your own computer—at home or 
at work—to upload your web site, you can ignore 
this section.

But if you’re working on a public computer—in 
a school computer lab or classroom—it’s vi-
tal that you remove your site definition from 
Dreamweaver before you leave that computer.

If you don’t, others who work on that computer 
later can accidently or intentionally upload docu-
ments to your web account.

To remove your site definition:

�. Select the Site > Manage Sites… menu item.

�. In the Manage Sites dialog (Figure 4.7) select 
the name of the site and click Remove.

�. 

Figure �.� To remove a site definition in Dreamweaver, 
in the Manage Sites dialog, select the name of  the site 
and click Remove.
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Cascading Style Sheets (CSS) make understand-
ing web pages a little more complicated, but once 
you get the hang of it, it makes developing web 
pages much simpler and easier. 

The idea is that you have a single CSS document 
that holds almost all the style information for any 
number of HTML pages that link to it.

When you want to change the text color, or font-
family, or type size, or any of dozens of other 
properties across your entire web site, includ-
ing some page layout information, you need not 
open and edit every HTML page. Instead you 
open and edit a single CSS document, and all the 
pages that link to it instantly reflect your changes.

Another advantage is that it keeps content and 
styling separate for folks who benefit from that, 
such as individuals with disabilities who need to 
increase text size or use screen reader software 
or other adaptive devices to use your web pages. 
When you use a separate style sheet, they can 
disconnect your styles or override them with 
their own to provide better access.

As I said, they make for a little slower learning 
curve, but the payoff for you and your users is 
well worth the effort!
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Figure �.� A segment of  the index.htm page in Design 
view with CSS styles turned off.

How does CSS work?
CSS stands for Cascading Style Sheets. A “style 
sheet” is just a list of display rules you can apply 
to any web page in whole or in part (Figure 4.1).

For example, lines 8 to 14 of the style sheet for the 
portfolio template show the rule to specify some 
properties of the HTML body tag:

body {
 font-size: small;
 font-family: Verdana, Arial, SunSans-Regu-
lar, Sans-Serif;
 color: #564b47;
 padding: 0px;
 margin: 0px;
}

This rule specifies that all text within the web 
page’s body tag will be in “small” font size, use 
the “Verdana” (or similar) type font, and be of a 
certain color (specified here in hexidecimal form).

To view a page without style sheets:

�. Select View > Toolbars > Style Rendering.

�. Click on the  (Toggle displaying of CSS 
files) button (Figure 4.2).

�. Click the same button to turn CSS back on 
(Figure 4.3).

Figure �.� Part of  the cascading style sheet for the 
portfolio template.

Using Styles for Layout

Remember that the page layout is made up 
of several rectangular boxes or layers (divs). 
Notice that the position and other properties 
of these boxes are also controlled by the style 
sheets (compare Figures 4.2 and 4.3).
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What can you do with CSS?
Dreamweaver let’s you view and control all the 
properties for any rule in your style sheet, with-
out resorting to opening the style sheet itself.

To view the properties of a CSS rule:

�. In the CSS palette, select the CSS Styles tab.

�. Under All rules, open the portfolio.css list.

�. Select the #content rule.

�. Click the  (Edit Styles…) button.

�. In the CSS Rule Definition dialog, click 
on each Category in turn, and notice which 
properties belong to which categories.

Figure �.� The same segment of  the index.htm page in 
Design view with CSS styles turned on.

What’s in a CSS style?

Even though each of the CSS style rules list-
ed in the portfolio style sheet look different, 
they can all contain exactly the same proper-
ties. For example, any CSS style element can 
contain a font-family property.

Only properties you want to change need be 
included in a specific rule. The rest default to 
previous or “higher” styles, or to the default 
HTML style. So, unless you specify a font-
family somewhere in your style sheet, the 
browser will display it in the default HTML 
style, Times Roman.Figure �.� The CSS Rule Definition for the Content div 

in portfolio.css, with the “box” tab showing.

Figure �.� The CSS Styles tab in the CSS palette, show-
ing the Properties for the Content id rule.
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The CSS Box Model
Before we start changing CSS rules, we should 
understand the “CSS Box Model.” The box cat-
egory of properties define the rectangle that sur-
rounds any element to which the rule is applied.

Study Figure 4.6. Perhaps the best way to think 
of this is to begin with the solid line, indicating 
the edge of the box around this element.

The content—in this case the “I want to make…” 
text—is indicated by the dotted line. Notice how 
the content is pushed in from the edge of the 
solid-line box by the Padding. 

The solid-line box, in turn, pushes away from 
everything else outside it with the Margin, indi-
cated here by the dashed line.

Let’s change some of the box properties of the 
body tag rule in portfolio.css.

To change a CSS rule:

�. With the index.htm page open, in the CSS 
palette, select the CSS Styles tab.

�. Under All rules, select the p, h�, h� rule.

�. In the Properties for “p, h�, h�” window, 
click in the padding property values field.

�. Change �0px to �0px, and change 80px to 
�00px.

This increases the right and left padding by 20 
pixels each, increasing the white space around 
the text (see Figure 4.8) and decreasing the width 
of the text block.

If you have trouble seeing the change, make the 
same values larger, or restore the original values 
while watching the effects on the index.htm page 
closely in the Design view.

Figure �.� A simplified diagram of  the CSS box model.

The order of box model values

Whenever you find four values defining a 
CSS box—whether it is margins or padding 
or anything else—they’re always in clock-
wise order starting from the top: top-right-
bottom-left.

Figure �.� Changing the right and left padding of  the 
p, h�, h� rule to 40 pixels and 100 pixels, respectively.
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Figure �.8 The index.htm page with increased padding 
in the p, h�, h� rule..

When do I save the style sheet?

If portfolio.css is locked when you begin 
to edit the style sheet, Dreamweaver will ask 
you if you want to unlock it and check it out. 
Generally, you do.

If portfolio.css is unlocked but not open, 
Dreamweaver will save any changes you 
make automatically.

If portfolio.css is unlocked and open, 
Dreamweaver will ask if you want to save it 
when you either go to close it or to browse 
any page linked to it. 

Generally, you will want to save changes to 
portfolio.css. You have a backup, right?

Figure �.9 The same page with the original padding 
restored to the p, h�, h� rule.

Rules that apply to several tags

A single CSS rule can apply to more than one 
HTML element, such as the p, h�, h� rule 
shown in Figure 4.7. This rule will apply to 
all HTML elements with any one of these 
tags (paragraph, heading 1, and heading 2).

Any time you change the style sheet, the changes 
apply to all pages that link to that style sheet. To 
test this, change the p, h�, h� padding property 
again and then open and preview any of the 
other pages in your portfolio folder.

Notice that you don’t need to save any changes to 
index.htm or any of the other files, because you 
didn’t make any changes to them. All the changes 
were in the portfolio.css style sheet—the list of 
rules to which these pages subscribe.

The beauty of cascading style sheets!
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Which rule applies?
You want to change the size of the text on your 
pages, and you know it must be somewhere in 
the style sheet, but you don’t know whether the 
rule that determines font-size is in the html rule 
or the body rule or the content rule or…? 

One of the trickiest parts about editing web pages 
that use cascading style sheets (CSS) is that it can 
be a little difficult to determine which rules are 
affecting which elements. 

Luckily, Dreamweaver provides some tools to help 
you narrow your search.

To find out which rules apply to a 
specific HTML element:

�. Insert your cursor in the element you wish to 
change. For this example, we’ll use the “Wel-
come” heading in index.htm (Figure 4.11).

�. Select Current in the CSS Styles tab of the 
CSS palette.

�. Select font-size in the Summary for Selec-
tion list. The About “font-size” panel indi-
cates that font-size is defined in rule “h1” in 
portfolio.css.

�. Use the Properties for “h�” to modify the 
font-size property that controls your selection. 
Remember, this will change the font-size  for 
all h� headings throughout your web site!

Figure �.�� The index.htm page with the cursor placed 
in the “Welcome” heading.

Figure �.�� The font-size property in the “h1” rule is  
the one in force for this selection.
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When rules don’t count

Remember that more than one rule can be 
assigned to any web page element (such as 
the “Welcome” heading in index.htm)? And 
more than one rule might specify the same 
property, such as font-size. And remember 
that it is the rule “closest” to the element that 
overrides most other rules cascading down?

Dreamweaver tries to help you sort all this 
out. In the Summary for Selection list, 
select font-family, which turns out to be 
defined in the body rule. Notice that there’s 
a font-size property specified in the body 
rule, but it is crossed out in Figure 4.13. That 
means this particular property is overridden 
by another rule, and changing it won’t help!

Figure �.�� The font-size property in the “body” rule is 
not the one in force for this selection.

Try some ch-ch-ch-changes?
The best way to understand the relationship 
between your style sheet and your web page is 
to make some changes in the style sheet and see 
what happens.

There are over 70 different properties that might 
be included in any given rule, but some are used 
more than others.

Use the procedures outlined in the previous 
pages to locate and change some of the properties 
of your page. If you like the changes you make, 
you may keep them—it’ll make your portfolio 
distinctive. Be sure you keep only changes that 
are in the spirit of the four design principles!

• The font-family for the body copy in the con-
tent div.

• The color of the text for the main page heading 
(“Welcome” in index.htm).

• The padding on either side of the body copy in 
the content div (try more white space).

• Any of the styles relating to the pageTitle (the 
word “Portfolio” in the banner on index.htm).
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How not to change styles
For those of us used to word processors and 
similar software, a more “intuitive” way to 
apply styles is to use the Properties palette 
(Figure 4.14). You may still do that when using a 
style sheet, but you must be careful which con-
trols you use.

If you’re not careful, you may be inadvertently 
generating new CSS rules within each HTML 
page you edit, instead of placing them in the style 
sheet where they belong—where they will be use-
ful on other pages in your site.

The fields to not use in the Properties palette 
(Figure 4.14) are:

• Font

• Size

• Color

O O O

Figure �.�� The Properties palette showing fields to avoid, when using CSS: the Font, Size, and Color fields.

Checking for unwanted styles

If you inadvertently let Dreamweaver insert 
an extraneous style into your HTML docu-
ment (Figure 4.15), it will appear in two 
places: as a style definition in the head of 
your document, and as a class modifying a 
tag in the body of the document.

Simply delete both, then work with your 
style sheet to accomplish the result you in-
tended.

Figure �.�� The Split view of  index.htm with an extra-
neous style (.style1) defined in the head and called as 
a class in a span tag in the body.
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Adding CSS rule properties

Dreamweaver let’s you add properties to any rule 
in your style sheet, or add an entirely new rule.

IMPORTANT: Adding new rules before you 
understand clearly how and where existing rules 
work can be risky, and result in confusion (of you 
and the style sheet). Treat this section as optional 
“enrichment” until you feel comfortable with 
CSS. Or make some changes but don’t save them 
until you’re sure everything is working OK.

To add a property to a CSS rule:

�. With the rule you want to add to displayed in 
the CSS palette (Figure 4.16), click on the Add 
Property link.

�. From the new pop-up field, select the prop-
erty you wish to add.

�. Complete the value fields (Figure 1.16). These 
will vary depending on the property you have 
chosen.

�. Note the result in your HTML document 
(Figure 4.17). 

�. If you want to make the change available to 
all the pages in your site, save your style sheet 
(portfolio.css). 

Figure �.�� The index.htm file with the h1 tag (see the 
word “Welcome”) showing the newly added letter-spac-
ing property.

Figure �.�� Adding the letter-spacing property to the 
h1 rule.
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So far, so good?
In the next session, we’ll begin making substan-
tial changes to the template: adding images, 
setting a color scheme, and otherwise making the 
portfolio really your own.

In the meantime, keep adding to the content.

The template comes with the following pages:

• index.htm - the Welcome page.

• gallery.htm - where you can list your accom-
plishments

• contact.htm - to help folks get in touch with 
you.

• copyright.htm - to help you protect your intel-
lectual property.

You’ve also added a biography page (bio.htm) 
and you might consider adding content to these 
or even adding additional pages, if you wish.
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What distinguishes the web with respect to mul-
timedia development is its narrow bandwidth. 
Think of bandwidth as the size of the “pipe” that 
connects your computer with the Internet, and 
the content of your site as water that needs to 
flow through the pipe. Pipe sizes range from very 
narrow (56k modems) to very wide (DSL, LAN).

The bigger the pipe, the faster your access to the 
images, animations, videos, and sounds that, 
along with text, make up the content of Web-
based multimedia.

As developers of educational multimedia prod-
ucts, we have to know how big a pipe our learn-
ers have, and make sure that we’re not trying 
to squeeze so much stuff through it that those 
users experience frustrating delays receiving and 
displaying it on their screens. Fortunately, there 
are a variety of ways to squeeze—compress—all 
kinds of media before we send it down the pipe, 
making it show up faster and reducing wait time 
for the end user.

That’s one of the main themes of this session: 
acquiring images and squeezing them into small 
packages to meet user needs and performance ex-
pectations. In a few years, increasing bandwidth 
may make this concern almost negligible. But for 
now, media compression goes with the territory 
of Web multimedia development.
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Obtaining images for your 
projects
There are lots of ways to get images for your edu-
cational multimedia products. You can:

• Get images from clip art libraries. 

• Shoot digital photographs and download them 
onto your computer. 

• Take conventional photographs and scan them 
directly to your computer hard disk. 

• Use computer drawing programs such as Mac-
romedia Freehand or Flash or Adobe Illustrator 
to create original artwork. 

• Download images from Web libraries or even 
ordinary Web pages (see Who owns an image?). 

Adding photos to your portfolio

For this exercise you can choose to scan a photo-
graph that you have or download a digital photo 
of yourself to replace the picture of Jane Doe 
(Figure 5.1). We’ll use Adobe Photoshop for both 
methods, but you can use the digital image edit-
ing software of your choice.

Who owns an image?

Please don’t forget that everything on the 
web is copyrighted. Period. You may not 
copy anything—even for educational pur-
poses—without permission of the copyright 
owner. Email people to ask permission. It’s 
fun and usually results in great networking. 
Where licensing agreements are posted for 
clip art libraries, read them carefully and be 
sure to adhere to their terms.

Figure �.� Jane’s friend snapped this shot of  her in 
a medieval village in France. She’ll use it throughout 
much of  this exercise.
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Using Digital Photographs
You can use any digital picture you have stored 
locally in your computer or on disk.

�. In Photoshop, click on File > Open. 

�. Use the Look in drop down menu to find the 
digital photo you want to use (Figure 5.2).

�. Select the image and click Open.

You’re now ready to edit the image. Skip ahead 
to the Crop Image section in this book.

Figure �.� The Adobe Photoshop Look in dialog box.

¸	Tip

n	Photoshop is a big, complex program in its 
own right. What we’re doing barely scratches 
the surface. See the Photoshop help menu for 
much, much more you can do with it.
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Scanning images onto your 
computer
In some ways scanning is much like photocopy-
ing. You put your original face down on a glass 
bed, set some settings, press a button, but, in-
stead of coming out as paper copy, the image ap-
pears on your computer screen. However, before 
you can put your scanned image online, you are 
going to have to make some further changes to it.

There are two sets of software involved in creat-
ing Web images from prints: one for scanning 
and one to edit images. Image editors allow you 
to do such things as lighten or darken a digital 
image, crop it, alter colors, resize it and, crucially 
for the web, reduce the file size. Although you 
can use each type of program independently 
of the other, many people run the scanner from 
within the image editor. We will do that here.

There are many image editors available, ranging 
from the immensely sophisticated and expensive 
(Photoshop and Fireworks) to more limited free-
ware such as Graphic Converter. You may also en-
counter some powerful mid-range programs such 
as Ulead’s PhotoImpact or Photoshop Elements. If 
you buy a scanner, you’ll probably discover that 
some form of image editing software is included 
as part of the package.   

By way of general illustration, we’ll use Adobe 
Photoshop to prepare an image for inclusion on 
a web site (referring, from time to time, to ways 
other programs carry out the same functions.) 
Here’s an outline of the stages in the process:

Figure �.� Placing a photographic print face down on 
the scanner bed.

¸	Tip

n	Menus, buttons, and other features differ 
among image editing applications and from 
scanner to scanner, but this example will give 
you an idea of what to look for and how to 
adjust various settings.

Figure �.� Select your scanner or scanning software 
from Photoshop’s File > Import… menu item.
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Figure �.� Your scanning software will look a little dif-
ferent, but many of  the features will be similar to these.

To pre-scan and scan:

�. With your scanner turned on and your com-
puter up and running, lift the cover of the 
scanner and place your photo, face down, in 
the designated position (Figure 5.3).

�. Open Photoshop.  Click on File and select 
Import. Within Import select your scanner or 
scanning software (Figure 5.4).

�. In your scanning software, make selection 
such as whether you image will be scanned in 
color or black and white (Figure 5.5, feature 
A).

�. Set the resolution of the image at 150-200 dpi 
(dots per inch) (Figure 5.5, feature B).

�. Click on Prescan (Figure 5.6, feature C).

�. Outline the area you want to scan by drag-
ging the edges of the box defined by the mov-
ing dotted line (commonly called “marching 
ants”). This is called cropping (Figure 5.6, 
feature D).

�. Once you have defined the area of your final 
image, click Scan.

8. The digital image will appear in a Photoshop 
document window. To start working on the 
image, close the scanning software.

Figure �.� Prescan and then crop your image in the 
preview window.

Figure �.� The digital image will appear in a Photoshop 
document window.

¸	Tip

n	After scanning an image, save it in the resolu-
tion and size at which you scanned it. A good 
location would be your offline folder. That 
way, after you’ve edited the image, resized it, 
and saved it for the web, if you’re unhappy 
with the results or want to use it for some-
thing else, you can always go back to the 
original scanned image and start over.
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Figure �.8 The “marching ants” define the new outline 
of  the cropped image.

Editing images
Depending on how your image looks, you may 
want to touch it up a bit.  There is an endless 
variety of things you can do, but here are some of 
the most useful—and unusual—enhancements.

To crop an image:

�. Use the marquee tool  to define the exact 
boundaries of your cropped image.

�. To implement the crop, select the Image > 
Crop menu item.

To enhance image tone and color:

You can adjust color and tonal qualities of the im-
age in a variety of ways. 

Auto Levels and Auto Contrast in Photoshop of-
fer the easiest ways of improving the appearance 
of an image. Try each in turn and use the Undo 
feature if you don’t like the result. 

Also try the Brightness/Contrast option. Other 
image editors will usually have at least a Bright-
ness/Contrast feature with which you can 
experiment.

�. In Photoshop select Image > Adjustments 
and the adjustment method you desire.

¸	Tips

n	If you make a succession of alterations that 
lead to an unpleasant final result, use the 
Photoshop History palette (located under the 
Window menu) to revert to any earlier point 
in the image manipulation process. Some 
other programs offer multiple Undos instead 
of a history function. 

n	The Help section in Photoshop will walk you 
through more image editing options if you’re 
feeling adventurous.

Figure �.9 Selecting Image > Adustments > Auto Lev-
els in Photoshop.

Figure �.�0 The History palette in Photoshop.
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To edit brightness, color balance, and 
saturation:

The Variations option in Photoshop lets you alter 
the brightness, color balance, and saturation of 
your image. It presents a selection of thumbnails 
of your image, so you can see how it will appear 
with, for example, more red or blue added.

�. Select the Image > Adjustments > Varia-
tions… menu item (Figure 5.11).

�. Click on the thumbnail image (Figure 5.12) 
representing the colors and shading you wish 
to apply.

�. Keep adjusting, or click OK to accept the way 
your image appears in the Current Pick 
thumbnail.

Image Displays on Macs and PCs

If you are developing on a Mac, it is worth 
bearing in mind that images display slightly 
brighter than they do on a PC. Consequently 
you may want to adjust your image to be just 
a little lighter than you think is optimal. 

Conversely, if you are a PC user, you should 
perhaps adjust your images a little darker 
than appears ideal.

Figure �.�� The Variations menu item.

Figure �.�� The Variations dialog showing thumnails 
for various color balances and brightness. Use the 
Saturation button at the top to vary how much color to 
to display in your image.
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To resize an image:

Once you have made color and tonal changes, 
you can now reduce the dimensions of your 
image to suit your page. Reducing the physical 
dimensions of an image is, of course, one impor-
tant step in making the image file size smaller (to 
load faster).

�. In Photoshop, select Image > Image Size… 
(Figure 5.13).

�. Make sure the Constrain Proportions box is 
checked.

�. Change the Resolution field to 72 pixels/inch 
(screen resolution).

�. Specify the final Height or Width in the Pixel 
Dimensions section. 

�. Click OK.

Figure �.�� Resizing an image in Photoshop.

¸	Tips

n	It is possible to make an image larger as well 
as smaller using the Size option, but “blow-
ing up” results in “pixilation”—making the 
pixels large enough to be seen individually. 
This is usually not a desirable effect. 

n	It is possible to change the dimensions of 
an image in Dreamweaver or other web page 
editors by shrinking or enlarging it. But this 
may result in making your users spend time 
downloading extra pixels they’re never going 
to see.

n	Solution:  scan your images larger than you 
think you’re going to need them, and then 
reduce them to the size you want using the 
image editor, before you insert them into your 
web page.
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To sharpen an image:

If your image is a bit out of focus or “soft”, you 
can sharpen it a little in Photoshop.

�. In Photoshop, select the Filter > Sharpen > 
Unsharp Mask… menu item.

�. Make sure Preview is checked.

�. Use the slider under Amount to sharpen the 
image. Don’t overdo the effect—a value of 
somewhere between 50% and 150% is prob-
ably appropriate (Figure 5.14).

�. When you are happy with your adjustments, 
click OK.

Figure �.�� Applying the Unsharp Mask to an image in 
Photoshop.
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Saving for the Web
You may know that there are three file formats 
used to display images on the web: JPEG, GIF, 
and PNG. Either JPEG or PNG 24 are appropri-
ate for photographic images, as each retains the 
range and subtle variation of colors in the origi-
nal. As JPEGs usually result in smaller file sizes, 
we’ll concentrate on them.

JPEGs compress files by selectively discarding 
data. When you convert a file to JPEG format, 
you can choose the level of compression and 
hence the amount of data discarded.

The greater the compression, the smaller the file 
size. However, the more data discarded, the more 
the image quality degrades. Photoshop, and other 
image editing programs like Fireworks, lets you 
preview an image for the Web at varying levels 
of compression, so you can choose the smallest 
acceptable file size.

To save a file for the web:

�. In Photoshop select File > Save for Web 
(Figure 5.15).

�. Use the control panel to select JPEG Medium 
in the Preset field.

�. Click Save and point the new image to the 
media directory in your portfolio folder.

�.  Give your image an appropriate name and 
click Save.

Figure �.�� JPEG Medium is usually a good setting to 
use with photos for web pages.

¸	Tip

n	Save your original scans and Photoshop docu-
ments (.psd) in your offline folder, separate 
from your portfolio web site. You never know 
when you’ll need to go back to the originals to 
resize, re-crop, or recompress to suit another 
purpose. If you throw it away, you’ll need it 
within minutes!
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JPEG Medium is usually a good setting for web 
images. By default you will see the optimized 
image at the compression level you have chosen, 
but you can use the tabs to compare the original 
to the compressed image (see the �-Up option in 
Figure 5.16).

In this instance the original was 91k; the medium 
quality JPEG is an acceptable 4.5k. 

As a rule of thumb, try to limit image file size to a 
maximum of 20k to 25k. And remember that sev-
eral images of that size in a single HTML docu-
ment will lead to an intolerably long wait for a 
page to load for a dial-up modem user.

Figure �.�� The �-Up tab in the Save for Web dialog 
box in Photoshop.
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Placing images on web pages
Before we begin, make sure you make a backup 
copy of your portfolio folder and save it in your 
offline folder.  

You can delete Jane’s image on your index.htm 
page and replace it with one that you have either 
scanned and saved or one that you took with a 
digital camera and downloaded to your hard 
drive.  

In both of these instances, we recommend that 
you crop and resize the image, if necessary, us-
ing your favorite photo editing software, such as 
Adobe Photoshop or Macromedia Fireworks and 
compress and save them appropriately for the 
web. 

Be sure to resize and compress before you insert 
the image in your web page. Don’t resize images 
within the web page itself.

To delete an image from a web page:

�. In Dreamweaver, open the page you wish to 
edit.

�. Click on the image to select it.

�. Press the Delete key on your keyboard.

Figure �.�� To delete an image from a web page in 
Dreamweaver, click on it to select it, and press the De-
lete key on your keyboard.

Figure �.�8 The Dreamweaver Assets panel with the im-
ages list showing, and the Insert and Refresh buttons 
at the bottom.

Figure �.�9 The Image Tag Accessibility Attributes 
dialog in Dreamweaver.
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To insert an image into a web page:

�. In Dreamweaver, open the page you wish to 
edit.

�. Place your cursor at the beginning of the text 
paragraph you want to wrap around it (in our 
example, just before the “I” in the first para-
graph of Jane’s welcome message).

�. In the Assets panel, select the  (Images) 
button (Figure 5.18).

�. Locate and select the image you wish to in-
sert. If your image is not listed, click the  
(Refresh site list) button at the bottom of the 
Assets panel (Figure 5.18).

�. Click the  (Insert) button at the 
bottom of the Assets panel (Figure 5.18).

�. Enter a brief description of the image in the 
Alternate Tag dialog box (Figure 5.19).

�.  With the new image still selected, in the 
Properties panel, select imgleft in the Class 
pop-up menu (Figure 5.21).

This last action applies the imgleft class rule, 
stored in the portfolio.css style sheet, to the 
image, wrapping the text around it to the right 
(Figure 5.22).

Figure �.�0 The image appears at the spot where your 
cursor is located, embedded in the text.

Figure �.�� The imgleft class rule is stored in the 
portfolio.css style sheet, for use in any page where you 
want to display images.

Figure �.�� The imgleft class rule makes the text wrap 
around the image on the right.
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Color makes a difference.

Choose a color scheme that gives the impression 
you want for the audience you’ve chosen.

Choose an image for your banner that has these 
colors in it. It might be an abstract image, like 
a closeup of a flower, or a realistic image that 
says something about who you are or what you 
do. Try to choose something that fits the “wrap-
around” nature of your portfolio menu.

Once you’ve chosen the color scheme and 
image(s) you want to include in your banner, 
you’re ready to put it together. We’ll show you 
how to do this in Adobe Photoshop, but you may 
also do it in other graphics programs such as 
Macromedia Fireworks and others.
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Customizing your banner
When you downloaded the template, you may 
remember seeing the template_images.psd file 
in your offline folder (Figure 6.2). The psd file 
extension stands for Photoshop Document.

Your new background image may be a JPEG or 
any other common format. It should be at least 
750 pixels wide and 575 pixels high. Larger is 
fine—you can crop and/or resize to fit (see Homer 
Session 5).

Jane is considering her wide range of skills and 
interests, so chose a somewhat abstract macro 
image of an iris (Figure �.�) she found on 
Flickr.com. The image is a public one, so she 
doesn’t need to worry about infringing copy-
right. It is large—about 1024 x 683 pixels.

To add a new photo to your banner:

�. Place the photo you wish to use in the offline 
folder along with template_images.psd.

�. Open both the new image and the 
template_images.psd file in Adobe Photo-
shop.

�. In Photoshop, select the  (Move) tool 
and drag the new image on top of the 
template_images.psd window.

�. In the Photoshop Layers palette, the new im-
age will appear at the top as Layer 1. Double-
click the name “Layer 1” and give it a more 
descriptive name (Figure 6.4).

�. Drag the new layer down in the Layer palette 
until it is next to the bottom (Figure 6.4). It 
will appear “behind” the text and other lay-
ers, but “on top” of the “Background B&W” 
layer, hiding the old, grey background from 
view (Figure 6.5).

Figure �.� If  you haven’t moved it, you’ll find the tem-
plate_images.psd file in the edtec541/offline folder. 
(Notice the portfolio backups there, too.)

Figure �.� Here’s what the template_images.psd file 
should look like in Adobe Photoshop.

Figure �.� Here’s the image Jane wants to try to use 
for the background of  the banner.
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To adjust a banner image:

�. With the template_images.psd file open in 

Photoshop, click on the  (Slice) tool. This 
lets you see exactly how the different parts of 
the image will appear in the top and left lay-
ers in your portfolio banner.

�. In the Photoshop Layers pallette, select the 
new layer (in our example, we’ve called it 
“Iris”). See Figure 6.4.

�. Use the Move tool and the Edit > Trans-
form… menu item to move and resize the 
image until  it looks the way you want 
(Figure 6.6).

Figure �.� The Photoshop Layers pallete with the new 
image added to the template_images.psd file. At left, 
as it first appears. At right, after renaming and drag-
ging to the next from bottom layer.

¸	Tip

n	When resizing images in Photoshop, hold 
down the shift key to keep the aspect ratio—
the relationsip between the width and height, 
constant.

Figure �.� The new image as it appears in the next-to-
bottom layer in the template_images.psd file.

Figure �.� The new image after being resized and 
moved around in the template_images.psd file.
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Hiding a layer
The new background has very little detail in the 
area that will become the menu bar in Jane’s 
portfolio pages. 

If your image is similar, you may hide the Pho-
toshop layer called Menu Bar, which serves as a 
kind of mask in case there is a lot of busy detail 
underneath that might interfere with reading the 
menus.

To hide a layer in Photoshop:

�. In the Layers palette, select the layer you 
wish to hide (in our example, the Menu Bar 
layer).

�. Click on the   (Indicates layer visibility) 
button so that the eye icon disappears.

If you decide you need the mask again, just tog-
gle the Indicates layer visibility button back on. 
Other layers can be turned on and off similarly.

Figure �.� The template_images.psd file with the Menu 
Bar layer hidden.
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Editing text in Photoshop
Of course, you’ll want to change Jane Doe’s name 
to your own. It’s in the Title layer at the top of 
the Layers palette list.

To edit the text for your banner:

�. Select the Title layer in the Layers palette.

�. Choose the  (Text) tool in the Tool palette 
and select the “Jane Doe” text.

�. Type your own name or the title of the web 
site, replacing “Jane Doe.”

�. From the Select the font family pop-up 
menu in the Text tool bar (Figure 6.9), choose 
a type font that reflects the feeling you want 
to communicate to other professionals, or to 
another specific audience of your web site.

�.  From the Set the text color box in the Text 

tool bar (Figure 6.9), select a color that con-
trasts sufficiently with the background.

If you need more contrast between text and 
background (as Jane does in this situation, where 
the light stripe runs through her name), consider 
adding a drop shadow.

To add a drop shadow:

�. Select the Layer > Layer Style… > Drop 
Shadow… menu item and adjust or accept the 
default settings (Figure 6.8).

¸	Tip

n	It can be a little tricky selecting type in Photo-
shop—watch to be sure you’re not creating a 
new type layer when you don’t intend one.

Figure �.8 The template_images.psd file with the Title 
layer given a new font, color, and drop shadow..

Figure �.9 The Text tool bar in Photoshop.
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Exporting slices
As you may have guessed when you selected the 
Slices button, we’re going to export the banner 
in several different pieces, or slices—three to be 
exact, corresponding to the top, left, and content 
layers in the portfolio web pages. The content 
layer image is just the little rounded corner slice.

To export slices for your web banner:

�. Select the File > Save for Web… menu item.

�. In the Save for Web dialog box, select the 

 (Slice Select Tool) button.

�. Click and shift-click to select the slices you 
wish to export (in our example, we need slices 
2, 3, and 5).

�. Select the JPEG Medium preset (Figure 6.10).

�. Click Save.

�. In the Save Optimized As dialog box 
(Figure 6.11): give the slices a new name; 
select the Images Only format (you won’t 
need the HTML in this case); use the Default 
Settings; and save only the Selected Slices. 
Point the new files to your media folder and 
click Save.

Figure �.�0 The template_images.psd file with the 
Menu Bar layer hidden.

¸	Tip

n	Don’t use the name “banner” for your slices—
some ISPs block any images with “banner” in 
the name, thinking they must be ads!

Figure �.�� In the Save Optimized As dialog, be sure 
to save the slices in your media folder with a sensible 
name.
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Organizing the slices
Before bringing the new banner slices into your 
portfolio pages, it’s important to organize them. 
File management, remember!

When you saved the slices, Photoshop created an 
images folder and added the slice number to 
each of the file names (Figure 6.12).

You’ll want to throw away any unused slices (we 
don’t need title_04.jpg), move the remaining 
slices into our media folder, and delete the now 
empty images folder (Figure 6.13).

To delete a file:

�. In Dreamweaver’s Local Files panel, select the 
file you wish to delete (in our example, the 
title_04.jpg file).

�. Right-click (Win) or Control-click (Mac) on the 
file you wish to delete.

�. From the pop-up menu, select Edit > Delete.

�. Verify when prompted.

To move a file:

�. In Dreamweaver’s Local Files panel, click and 
drag the file to the new location (in our exam-
ple, click and drag on title_02.jpg, dropping 
it into the media folder). See Figure 6.13.

Once you’ve moved all the new slices out of the 
images foler, delete the images folder the same 
way you delete a file.

Figure �.�� The portfolio/media folder showing the 
new images folder with the exported “slices.”

Figure �.�� The slices have been moved to the media 
folder, and the now empty images folder deleted.
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Placing banner images in 
your portfolio pages
To accomodate anomolies in Microsoft’s Internet 
Explorer browser, two of the three images that 
make up the banner in your portfolio pages are 
not in the style sheet, they are in the HTML pages 
themselves. That means you’ll need to update 
each of your pages individually. Best to do it now 
before you get too many pages made.

The following instructions will work if you 
have not made any changes to the various lay-
ers (divs) either in your HTML pages or in the 
portfolio.css style sheet. If you have made 
changes and are not sure about the integrity of 
those pages, now is the time to get a fresh copy 
of the portfolio template and start over, or at 
least copy and paste the top and left divs from an 
untouched version of the template into your own 
pages.

To insert an image in a layer:

�. In Dreamweaver’s Design view, select the im-
age (in our example, click on the image in the 
top div containing the “Jane Doe” banner.

�. In the Properties panel, click on the folder 
icon to the right of the Src field (Figure 6.15).

�. Locate the title_02.jpg image, select it, and 
click Choose.

Use the same procedure to place the 
title_03.jpg image in the left div.

Repeat this for each of your pages that use this 
template.

Figure �.�� The index.htm page with the new banner 
image slices inserted.

Figure �.�� The properties panel with the new title_
02.jpg selected in the Src field.
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Using background images
In some cases, you can use background images, 
though funny things in Microsoft Internet Explorer 
browser dictate caution.

To place an image in the background 
of a layer:

�. In Dreamweaver’s Design view, click any-
where in the content div.

�. In the status bar, select the <div#content>.

�. In the Properties for “#content” rule panel, 
change the background-image property 
to reflect the new rounded corner image 
slice (in our example, it is title_05.jpg). See 
Figure 6.16.

This is the only place you need to make this 
change. Remember, anything you do in the style 
sheet takes effect immediately in all the pages 
that subscribe or link to it.

Figure �.�� In the Properties for “#content” panel, set 
the background-image property to the new image.
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Extending the color scheme
Your new banner images make a color statement 
that you can extend to the rest of your web page.

To copy a color from an image to a 
web page element:

�. Select the part of the web page you wish to 
color (in our example, the top div).

�. In the Properties for “#top” panel 
(Figure 6.17), click on the background-color 
patch. The cursor turns into an eye dropper.

�. Click the tip of the eye dropper on the image 
color you wish to capture (in our example, 
click on the far right edge of the title_02.jpg 
image located in the top div). See Figure 6.18.

Repeat the same procedure for the left div, us-
ing a color from the extreme bottom edge of 
the title_03.jpg image. You won’t see anything 
change in the Design view, but the color exten-
sion below the left div will show up in your 
Firefox browser (Figure 6.19).

You may also change the background-color of 
the pageTitle div in the same way. For contrast, 
you could change the text color of the pageTitle 
div to one of the lighter colors from the banner.

Try changing the text color in the body rule to 
one of the darker shades from a banner image.

Notice how picking up different colors from 
your banner images to apply to your HTML page 
helps pull the whole thing together—repetition!

Figure �.�� The Properties for “#top” panel with the 
background-color property.

¸	Tip

n	Be sure to distinguish between the color prop-
erty and the background-color property. The 
color property controls the color of any text 
appearing in the element. The background-
color property controls the… background!

Figure �.�8 The background to the right of  the banner 
image is now a similar color as the banner image itself.

Figure �.�9 The new color scheme previewed in the 
Firefox browser, with colors picked up from the banner.
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What’s next?
In the next section, we’ll begin making changes 
to the navigation system, customize the menu 
to match our new content—and our new color 
scheme—and learn how to use Dreamweaver 
libraries to save time and tedium.
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navIGatInG
Coming up with a useful navigation scheme is 
easy if you just keep your audience in mind. Talk 
with a few of them, and find out how they want 
to look for information on your site. For example, 
if you discover they think about your content…

• temporally—as an event in history—give them 
a time line to quickly find what they seek; as a 
scheduled event—provide a calendar to link to 
information on those events;

• spatially—as a geographic or other physical lo-
cation—click on a map or diagram to get there; 
as a conceptual location—provide a clickable 
concept map;

• pictorially—when they know what the stuff 
looks like—let them have a picture gallery;

• alphabetically—when they know the name—
give them an alphabetical index;

• topically—when they understand how the 
material is organized—provide a hierarchical 
menu or table of contents;

• by association—when they’re looking for 
related information—use hyperlinks or a text 
search function;

• sequentially—going from one page to the 
next—browsing buttons (next and previous).

You’ll often use more than one of these, and sev-
eral are implemented with menus, like the ones 
you’ll learn to configure in this section.
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Flattening your site
Your portfolio is probably hierarchical in struc-
ture, with a main page that branches off to sub-
ordinate pages, which may, in turn branch off yet 
again. Hierarchical structure is often useful, espe-
cially for those new to your site who may become 
lost in more complex structures.

But it poses a bit of a navigation problem, es-
pecially when you have three or more levels in 
the hierarchy. Suppose a user comes to your site 
(Figure 7.1) at the index.htm page, clicks down 
to the links.htm page, and clicks down further to 
the links_pta.htm page. 

Next they want to post an idea to the bul-
letin board. Will you make them retrace 
their steps back up through links.htm to 
index.htm, then back down through ideas.htm 
to msg_post.htm? Every extra click throws up a 
barrier to continuing.

One way to make the structure of your site trans-
parent to users and, at the same time, provide 
access to every page with one or two clicks, is 
called “flattening” your site.

This method uses hierarchical menus that reflect 
the structure of your site. One click opens a menu 
to reveal subordinate pages, a second click takes 
you to the destination (Figure 7.2).

You can build a menu with simple hyperlinks, 
but to flatten your site effectively benefits from 
some extra functionality. Your portfolio template 
is fitted out with a very nice hierarchical drop-
down menu provided by Brothercake.com, that 
uses Javascript and the Dreamweaver Library 
function, which we’ll explore in this session.

Figure �.� Part of  a typical, hierarchical site map.

¸	Tip

n	Usability research indicates that three levels 
in a hierarchy are optimal, particularly if you 
have many new users coming to your site. 
More than three, users begin to be “lost in 
hyperspace.”

Figure �.� Here’s a slightly exaggerated (because it 
contains four levels) example of  a hierarchical menu.
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The Brothercake menu
There are many ways to build menus, but most 
hierarchical menus—menus that allow you to 
flatten a hierarchically organized site—use Ja-
vascript. The Ultimate Dropdown Menu (UDM) by 
Brothercake is no exception.

We’ve been using the UDM for several years 
in our own web work. It is free for personal or 
non-commercial use (see the license agreement 
for details), it contains most all the features one 
could reasonably want, it is highly customizable, 
it is reliably cross-platform and cross-browser, 
and facilitates a high degree of accessibility.

The Jane Doe portfolio template has 
UDM version 4.45 already installed in 
it. For the latest version and additional 
documentation, see the UDM web site: 
http://www.brothercake.com/dropdown/

In this section we’ll see how UDM works and 
how to customize it to meet our portfolio needs. 
Every UDM menu is made up of these parts:

• An unordered (bulleted) list in the body of the 
HTML page provides the content—text and 
links—for the dropdown menus (Figure 7.3).

• The udm-resources folder (Figure 7.4) con-
tains the Javascript documents and images 
used to hide the menu list in the HTML body 
and display it instead as a dropdown menu.

• Links and Javascript in the HTML head and 
body (Figure 1.13) that call the appropriate 
scripts to construct the menu in the web brows-
er. Remember, you won’t see the menu itself 
in Dreamweaver, only when you preview it in a 
web browser.

¸	Tip

n	Never edit the portfolio menu in any of the 
HTML pages themselves. Always edit it in the 
site Library, so that changes will be available 
to all the HTML pages to which it is linked. 
See the next page for details.

Figure �.� Code view of  index.htm showing part of  the 
unordered list in the body of  the HTML that provides 
the content—text and links—for the dropdown menus.

Figure �.� Dreamweaver’s Files window showing the 
udm-resources folder and its contents.
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Editing menu contents
The text and links that make up the menu are 
contained in an unordered list (Figure 7.3) at the 
bottom of every HTML page in the site.

To change the menus across the site, you must 
change the list in every page. This would be a 
chore if you had dozens of pages (which you will, 
eventually). To ease that chore, we’ve made the 
menu list a Dreamweaver Library item.

A Library item (Figure 7.5) is a separate docu-
ment containing content used in multiple pages 
in a site. Dreamweaver keeps track of what items 
go on which pages, so when you update the 
Library item, Dreamweaver prompts you to auto-
matically update all the pages that use that item.

To edit a Library item:

�. In Dreamweaver’s Assets panel, select the 
(Library) button. You’ll see a list of Library 
items in the site (Figure 7.5).

�. Double-click the item you wish to edit (in 
our example, the main_menu_tree item. The 
Library item document will open (Figure 7.6).

Figure �.� Dreamweaver’s Assets panel with the Li-
brary category selected, showing the main menu tree.

Figure �.� The main_menu_tree Library document 
open in Dreamweaver’s Design view, showing the 
changes to the unordered list that will become the 
dropdown menu.
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To edit the text of a menu item:

�. In Dreamweaver’s Design view, select any 
menu item (any line in the unordered list).

�. Type the new text for that menu item 
(Figure 7.6).

To edit the link for a menu item:

�. With any item (any single line) in the 
main_menu_tree document selected,  
click on the folder icon next to the Link field 
in the Properties panel, and navigate to and 
select the page to which you wish to link.

Figure �.� The Link field in Dreamweaver’s Properties 
panel with the About me menu item selected in the 
main menu tree Library item document.

¸	Tip

n	Notice that relative links (links to other pages 
within the present web site) in the Library 
have paths that begin with “../”. This path 
leads up and out of the Library folder and 
into the rest of the site, where the linked pages 
are. This path will be changed automatically 
to match the correct path for the specific page 
in which the Library item is embedded. Leave 
this alone, and let Dreamweaver take care of it.

Relative vs. absolute links

Relative links are those from one web page 
to another within the same domain. They 
consist of just that part of the path to get 
from one page to another:

<a href="../assign/ments.htm">

Absolute links are those between two pages, 
whether or not they are in the same domain. 
They always contain the "http://" prefix and 
the destination domain name, along with the 
full path name:

<a href="http://new.domain.edu/portfolio/
bio.htm">
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To edit the title attribute for a link:

If there is already a title attribute for that link…

�. In Dreamweaver’s Code view (Figure 7.8) or 
Split view, locate the <a href> tag that corre-
sponds to the link you wish to title.

�. Select the text inside the double quotations 
and type the new title attribute.

If no title attribute yet exists for that item…

�. In Dreamweaver’s Code View place your cur-
sor after the path name (in our example, after 
<a href=”../about.htm”) and before the close 
of the tag (>).

�. Type your new title using this syntax:

title=”About Jane Doe”

Figure �.8 Dreamweaver’s Code view of  the main menu tree Library item document, showing the “well formed” 
structure of  the unordered list, with title tags added to the menu item links.

¸	Tip

n	The UDM will only work if the unorderd list 
remains “well formed,” that is, follows HTML 
rules for nesting the levels of the hierarchi-
cal list. Specifically, each <ul> tag must be 
closed (</ul>) only after all its <li> tags are 
closed. And each <li> tag must be closed 
(</li>) before another <li> tag may begin (see 
Figure 7.8). If part or all of your menu doesn’t 
work, check this “well-formed-ness” first.

What are those tags for?

The <ul> tag signals the beginning of an un-
ordered list, what we usually call a bulleted 
list (as opposed to an <ol> ordered list that is 
numbered 1, 2, 3… and so forth).

The <li> tag is used for each line of a list (ei-
ther ordered or unordered).

What are title attributes?

Not to be confused with the title tag in the 
page head that displays in the page’s title 
bar, these titles are attributes of a link tag.

They show up when you roll your mouse 
over the link in a browser. They tell the user 
what to expect when they follow that link. 
They can also be read by automatic screen 
readers, helping make your pages accessible 
to users with visual disabilities.
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To update the web pages with the 
edited Library item:

�. With the Library item document 
main_menu_tree open in Dreamweaver, select 
the File > Save menu item.

�. The Update Library Items dialog 
(Figure 7.9) should appear, listing the HTML 
files that contain copies of that Library item. 
Click Update.

�. If Dreamweaver needs to update files that are 
checked in, it will ask permission to check 
them out. Click on Yes to All. In a large site, 
this may be dozens of files.

�. When Dreamweaver finishes updating your 
files, it will return to the Update Pages dia-
log box (Figure �.�0). Click on Close.

�. Check all updated files back into the server.

�. Test the new menu from a browser.

¸	Tip

n	If you’ve inadvertently broken the connection 
between the Library item and the HTML pag-
es (if you’ve backed up your portfolio folder 
within Dreamweaver, for instance, or moved 
it or the Library in Dreamweaver’s Files win-
dow) you’ll get an error message indicating 
that DW can’t find the Library item and you 
will need to re-establish the connection.  
 
To re-establish the connection, select and 
delete the main menu tree Library item in 
each HTML document, then re-insert the Li-
brary item in each document from the Assets 
window. See Dreamweaver’s Help menu under 
“Inserting a library item in a document.”

Figure �.9 Dreamweaver’s Update Library Items dialog 
box, asking if  you want to update your pages with the 
changes to the menu? Usually you will click Update.

Figure �.�0 Dreamweaver’s Update Pages dialog box 
after finishing updating all the HTML files that use the 
main menu tree Library item.
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Configuring the menu system
As you’ve seen, changing the contents of the 
menu takes place in the HTML pages by edit-
ing the main_menu_tree Library document and 
then updating that in all the HTML pages.

Configuring the menu—changing colors and 
text styles and many other attributes—is done in 
an entirely different place, the udm-custom.js 
file, located in the udm-resources folder in your 
portfolio folder.

It looks a little daunting, but in the next few 
pages you’ll see how to zoom in on the useful 
bits and ignore the rest. For starters, do not—do 
not—edit any of the other Javascript (.js) files 
in the udm-resources folder. Just… leave them 
alone. Thank you.

To configure your portfolio menu:

�. In Dreamweaver’s Files window, open the 
udm-resources folder and double-click the 
udm-custom.js file.

�. Edit one or more attributes (see rules, below).

�. Save udm-custom.js, switch to a page with 
the menu, and preview results in a browser.

Editing rules:

• Do not edit anything above the section titled 
Core Configuration (Figure 7.11).

• Edit only those attributes shown in blue type.

• Preserve the syntax (spacing, punctuation, 
case) exactly.

• Use only the parameters listed in the greyed-
out comments to the right of each attribute.

• Edit and preview one attribute at a time, so 
you can recover easily from mistakes.

Figure �.�� Dreamweaver’s Code view (the only view 
available) of  the udm-custom.js file.

¸	Tip

n	We’ll be showing you how to customize sev-
eral of the most important menu attributes, 
but at times you may want more information.  
 
You’ll find thorough documentation on any 
attribute at: 
 
http://www.udm4.com/manual/customising/
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Figure �.�� The index.htm page with the default verti-
cal menu orientation.

To change from a vertical to a 
horizontal navbar:

Please don’t consider the following a recommen-
dation that you change the orientation of your 
navbar right now. The template is designed to 
use a vertical navbar, and, especially if you’re 
a beginner at either web page development or 
graphic design, you’re better off leaving it as is. 

Nevertheless, there will be more experienced 
developers and/or graphic artists among us who 
can handle the challenges of this change, and 
you’re welcome to play with it.

For now, just try the change from vertical to hori-
zontal for a few minutes to see what happens, 
then change back to vertical.

�. In udm-custom.js, find um.orientation and 
change alignment from "vertical" (Figure 7.11) 
by selecting it and typing "horizontal" (be sure 
to keep quotation marks and all other syntax 
intact).

�. Save udm-custom.js, switch to index.htm 
(or any other HTML page that uses the menu) 
and preview it in a web browser (Figure 7.13).

Notice that the new navbar is not necessarily po-
sitioned in the best place on the page. Should you 
wish to keep the horizontal orientation, adjust 
the left, top, and other attributes under navbar 
orientation in udm-custom.js, changing one or 
two attributes at a time, saving, then previewing 
in your browser until it looks the way you want 
it. For additional help, refer to:

http://www.udm4.com/manual/customising/
core/#customising-core-orientation

To revert to the original vertical orientation, 
repeat steps 1-2 (above) but substitute "vertical" 
for "horizontal." After saving udm-custom.js and 
previewing your HTML page in the browser, it 
should once again look like Figure 7.12.

Figure �.�� The same index.htm page with the horizon-
tal menu orientation, not yet positioned.
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To edit the UDM navbar:

The UDM refers to the main navigation strip or 
column as the “navbar,” and we’ll adopt that 
terminology in this section.

�. In udm-custom.js, scroll down to the Navbar 
Default Styles section.

�. Refer to Figure 7.14 to identify and change 
various elements in the UDM navbar.

�. Change one or two attributes at a time, save, 
and preview the changes before continuing.

Figure �.�� The Navbar Default Styles section of  udm-custom.js, with ranges of  attributes connected with fea-
tures of  the actual menu as it is displayed in a web browser.

For more navbar information…

http://www.udm4.com/manual/customising/
navstyles/



8�

Navigating

To edit the UDM menus and items:

Use the same methods as for the UDM navbar, 
but make your changes in the Menu Default 
Styles section of udm-custom.js.

To assign colors to UDM attributes:

As you assign text colors, background colors, and 
border colors to your UDM navbar and menu, 
you’ll want, no doubt, to pick up colors from 
your banner images or from your existing color 
scheme.

Because you must edit udm-custom.js in the 
Code view window, you can’t use the eye-drop-
per tool directly to pick up colors from your web 
page and assign them to UDM attributes.

But you can accomplish the same thing indirectly.

�. In Dreamweaver, open index.htm or any one 
of your pages that already has your color 
scheme.

�. Click on any element that has color assigned 
to it—the text in the content div, for example.

�. In the Properties panel, use the  (Text 
Color) pop-up menu to obtain an eye-dropper 
tool.

�. Move your eye dropper over the various im-
ages and other colors in your page, to see the 
hexidecimal code for each color (Figure 7.15).

�. Without clicking on the color (that will assign 
the color where you don’t want it), make a 
note of the hexidecimal code.

�. Click back in the  (Text Color) pop-up 
menu to cancel any changes to the text color.

�. Switch back to udm-custom.js and type the 
new code into the attribute.

¸	Tips

n	The codes you see in the default template 
have been shortened from 6-characters to 3-
characters. For example, the border color for 
the menus reads something like: 
 
#f00 #036 #f00 #036 
 
These are simply shorthand for the full 6-
character code that would look like this: 
 
#ff0000 #003366 #ff0000 #003366 
 
Notice that each character is simply repeated. 
Not all colors use repeats, however, and in 
those cases you must use 6-character codes.

n	When you see four colors or other attributes 
listed in a row, as you do in the previous ex-
ample, they map onto a rectangular shape, in 
order as follows: top, right, bottom, left.

Figure �.�� As you roll your mouse over colors on your 
web page, you’ll see the hexidecimal code reflected in 
the Text Color field.
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acceSSIBIlIty
In the narrow, legal sense, accessibility refers to 
making web pages usable by people with a va-
riety of disabilities—visual, auditory, and motor 
(can’t use a computer mouse, for example).

These users often use what are called adaptive 
technologies—screen readers to convert text to 
speech, zoom controls to enlarge screens, special 
interface elements like large keyboards, and the 
like.

Federal and state laws require that organizations 
that serve the public make their services available 
to everyone. This applies to hallways, doors, and, 
yes, to web sites. 

One response to this requirement is to make 
sure that any web site you develop meets a list 
of accessible design features specified by rel-
evant standards organizations. But there’s also a 
healthy response that steps back and says, “Hey, 
let’s just design our web sites to make them as ac-
cessible as we possibly can to everyone, whether 
they’re disabled or not.”

In this section, you’ll learn some strategies for 
implementing this latter approach, “universal 
usability”—a term coined by Sarah Horton at 
Dartmouth College. For more information on this 
approach, see her book entitled, Access by design: 
A guide to universal usability for web sites.
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Accessibility standards
First, let’s get the easy stuff out of the way. Your 
portfolio template is designed to help you in-
clude accessibility features specified by standards 
organizations to satisfy Federal and State require-
ments.

Notice that including these features in the tem-
plate is just the beginning. It’s up to you to keep 
building and testing your pages as you add 
content and modify the template to suit your 
audience’s needs.

How to check accessibility:

�. Browse a page from a web server. (This won’t 
work when you’re just previewing a page 
from your computer in a browser—it must be 
on a web server.)

�. Click on the Go button at the bottom of the 
content div. (Be sure you haven’t altered any 
of the code in the accessibility checking form 
(Figure 3.13).

�. In WebXACT, click on the Accessibility tab 
(Figure 8.1) for a report on Errors and Warn-
ings (Figure 8.1)

�. If you find an Error or Warning, note the line 
numbers (these refers to the line number in 
your Dreamweaver Code view) and click on 
the link for Guidance on how to fix it.

�. Find the line in Dreamweaver’s Code view and 
fix accordingly, if possible. 

¸	Tip

n	Sometimes we’ve found WebXACT to take an 
inordinately long time and/or give an error 
message. When that is the case, just abandon 
it for a few hours, then try again.

Who is responsible?

I like this quotation from Dreamweaver’s Help 
system:

“Remember that no authoring tool can au-
tomate the development process. Designing 
accessible websites requires you to under-
stand accessibility requirements and make 
many ongoing subjective decisions about 
how users with disabilities interact with web 
pages. The best way to ensure that a website 
is accessible is through deliberate planning, 
development, testing, and evaluation.”

Figure 8.� The WebXACT main report screen.

Figure 8.� The WebXACT Accessibility report screen, 
showing an error in the Priority 2 category.
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Accessibility features
Accessibility takes many forms, but here are 
some of the most common and easily taken care 
of as you are developing.

To accommodate visual disabilities:

• Include Alternative Text (Alt) tags for each im-
age describing the content of the image.

• Include Title attributes for all href tags that 
describe where the link will take the user.

• Use style sheets to provide page and text siz-
ing, so that users can substitute their own style 
sheets to enlarge text.

To accommodate aural disabilities:

• Provide text transcription of audio or sound 
video files.

To accommodate motor disabilities:

• Be sure users can navigate using only their 
keyboard, without a mouse.

Figure 8.� The WebXACT detail list for Priority 2, with 
links to information on how to correct errors, and rec-
ommendations for items a human must check.
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vIdeo on tHe WeB
For several years, the web was a “step back” from 
CD-ROM-based multimedia, because bandwidth 
considerations made video and audio—anything 
except text, still images, and very small anima-
tions—impractical. That is changing thanks to 
new compression schemes for video and audio, 
and faster Internet connections.

In this session, you will take an uncompressed 
digital video clip and:

• Compress it to an appropriate size for web 
delivery.

• Insert it into your web portfolio.

Along the way you will learn some additional 
HTML features, particularly those designed to 
assist visually impaired web users.

How does this fit into your web portfolio? For 
now, it’s just for you to see how to put video on 
the Web. Later, you can delete Jane’s video and 
substitute one of your own.  

You will need the following tools:

• Macromedia Dreamweaver

• Apple’s iMovie or Windows MovieMaker (or 
equivalent)

• An FTP program (we’ll use Dreamweaver’s 
built-in FTP)
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Pick on someone your own 
size
Video is the 600-pound gorilla of multimedia. It 
eats bandwidth for breakfast. 

Think about it. Like film, video is a series of still 
pictures. A single second of full-frame, full-mo-
tion video (the kind you watch on TV) involves 
flashing thirty 640x480-pixel (or larger) pictures 
onto the screen in rapid succession. 

Most computers, until the advent of 300+ MHz 
processors and fast hard drives, just couldn’t get 
that much data off the drive and onto the screen 
fast enough. Even now that computers them-
selves can handle it, if you want to send that kind 
of data to someone over the Internet you’ll run 
into the “narrow pipe” problem we discussed 
earlier in Homer.

What can you do to serve those important videos 
you’ve been creating for your web audience? You 
can control three variables that effect video file 
size:

�. The dimensions of the video window—in-
stead of 640x480-pixels, make it 240x180, 
192x144 (Figure 9.1), or smaller.

�. The frame rate—12 frames per second instead 
of 30 (for instance, 12 fps will more than halve 
the size from 30 fps).

�. The resolution and/or compression of the 
image (these are a bit different, but they often 
interact with one another—for simplification, 
we’ll treat them as one).

Figure 9.� The run.mov file shown in its original 
640x480 TV size, compared with its reduced 192x144 
pixel web dimensions (inset).
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Capturing video
We are giving you a video to use in this tutorial, 
but if we weren’t, the first step in getting video 
onto the Web is to capture it into your computer. 
The small digital video camcorders offer the 
best way yet to do that. They record the image 
as a digital signal, so you don’t actually need to 
“digitize” it again to get it into the computer. This 
saves some trouble for your computer, but it still 
happens in “real time”—at the speed of video 
playback.

Common consumer level analog video formats 
include VHS, S-VHS, 8mm and Hi-8. At this 
writing, there are two popular digital video (DV) 
formats: miniDV and DV-8 (the latter uses con-
ventional Hi-8 tape but records a digital signal).

Whatever kind of camcorder you have, you can 
get your video (please don’t call it “film”) into 
your Mac or PC. All Macintosh and PC comput-
ers now come with FireWire or USB2 ports that 
make capturing DV pretty straightforward. You 
can capture analog video as well, but you’ll need 
a special adapter or a DV camcorder to convert it 
to a digital signal first.

In either case, you basically connect a cable 
from your camcorder to the computer, and press 
“Capture” or “Record” in your computer’s video 
capture software application. Macs all ship with 
Apple’s iMovie, an excellent and easy-to-learn 
video capture and editing program. PCs usually 
come with Windows MovieMaker. Use the docu-
mentation that comes with your system to learn 
how to use these programs.
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How small is small?
To display any digital video on the web you have 
to first squeeze it reeeally small! How small? Let’s 
begin by looking at its current size.

To view file properties in Windows:

�. In Windows Explorer, select run.avi.

�. Double-click it to open, and click the Play 
button to see Jane run.

�. Right-click and select Properties. Make a 
note of the file size.

�. Click the Summary tab (Figure 9.2).

To view file properties in Macintosh:

�. In the Macintosh Finder, select run.mov.

�. Double-click run.mov to open it in QuickTime 
Player.

�. Click the Play button to see Jane run.

�. Select the Window > Show Movie Info… 
menu item (Figure 9.3).

Notice that both the run.avi and run.mov movies 
are 320x240 pixels, one quarter the size of a full 
TV screen. They are 15 fps (frames per second), 
half the size of a regular TV video. 

Notice that both the run.avi and the run.mov 
movies are roughly 650KB—over half a mega-
byte—all for a 2-second movie with no sound! 

And it would take several minutes to load into a 
browser on a dial-up modem!

Figure 9.� Windows Properties for the run.avi file.

Figure 9.� Macintosh Properties for run.mov.
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Compressing video
The process is the same, but the procedure is a 
little different depending on your platform. Here 
are some easy ways to compress video for the 
web.

To compress video in MovieMaker:

�. Open Windows MovieMaker.

�. Select the File > Import into Collections… 
menu item and select the run.avi movie.

�. Drag the clip into the timeline at the bottom 
of MovieMaker.

�. In the Movie Tasks column at left, click on 
Save to my computer.

�. When prompted, give your movie a name (in 
this example, “run”) and point it to save in 
your portfolio/media folder. Click Next.

�. When prompted to select a Movie Setting, 
choose Other settings and select Video 
for dial-up access (�8 kbps) or Video for 
ISDN (�8 kbps) (Figure 9.5). Click Next.

�. After the movie compresses and saves, click 
Finish.

This will create a compressed movie called 
run.wmv (Windows Media) and save it in your 
media folder. The file will be about 15K—it’ll 
load in a browser in a few seconds.

¸	Tip

n	Remember, the more compressed your movie 
is, the blurrier, jerkier, and smaller it will be. 
If you know that everyone in your audience 
has a fast connection, you may choose DSL, 
cable modem, or higher. Or if you have 
many slow and fast users, make two versions 
of your movie and give users a choice.

Figure 9.� Windows MovieMaker with run.avi opened in 
a Collection.

Figure 9.� MovieMaker’s Save Movie Wizard set for dial-
up modem bandwidth.
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To compress video in Apple’s iMovie:

�. Open Apple iMovie, and select Create a new 
project. Save the new project as run in your 
offline folder.

�. Select the File > Import… menu item, and 
open the run.mov movie.

�. Drag the clip into the timeline at the bottom 
of iMovie (Figure 9.6).

�. Select the File > Share… menu item.

�. Click on the QuickTime tab and select Com-
press movie for Web (Figure 9.7).

�. When prompted, save your movie as run.mov 
in your current portfolio/media folder.

This will compress your movie down to about 
75K—it’ll load in a browser in a minute or so on a 
dial-up connection. 

Figure 9.� iMovie’s QuickTime Sharing dialog tab, with 
Compress movie for Web selected.

Figure 9.� Apple iMovie with run.mov inserted in the 
timeline at the bottom of  the screen.

¸	Tip

n	Remember, the more compressed your movie 
is, the blurrier, jerkier, and smaller it will be. 
If you’re feeling a little adventurous, you can 
select Custom in step 5 and choose a specific 
size, compression algorithm, and frame rate. 
To start, try the settings shown in Figure 9.8.
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Placing video in a web page

To place a video in Dreamweaver on a 
Macintosh:

�. Open Dreamweaver and make a copy of any 
page, such as index.htm or bio.htm, in the 
top level of your portfolio folder.

�. Call the new page running.htm and give it a 
title like “Jane Running.”

�. Delete the text and images (except the head-
ing and the accessibility test line) from the 
content div of the new running.htm page.

�. With your cursor in the content div where the 
text used to be, click the  (Movies) button 
in the Assets panel, and select run.mov.

�. Click Insert in the Assets panel.

�. In the Properties panel, click on the Param-
eters… button and add three parameters (us-
ing the +  button). Fill in the Name and Value 
fields for each as in Figure 9.9.

Dreamweaver can’t tell the window size of the 
movie so you will have to set it yourself.

�. Click the  (Plug-in) icon to select it. 

8. In the Properties panel, set the width (W) 
and height (H) of the run movie to whatever 
you specified when you compressed it, add-
ing 16 pixels to the height to accommodate 
the controller. So, if your run.mov is 240x180, 
you would set W to 240 and H to 196.

9. In the Properties panel, set the Plg URL field 
to http://www.apple.com/quicktime

�0. In the Properties panel, click Play to preview 
your movie in the web page.

¸	Tip

n	If the run.mov isn’t there when you click 
the Movies button in the Assets panel, it 
could be because you didn’t save it into your 
media folder. If that’s the case, just find the 
new, compressed version and move it into 
the top level of the media folder. Back in 
Dreamweaver, refresh the Assets panel and try 
again.

Figure 9.8 iMovie’s Custom Movie Settings dialog with 
some suggested settings for a web movie.

Figure 9.9 Dreamweaver’s Movie Parameters window 
with appropriate parameters filled in.
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Placing video in a web page

To place a video in Dreamweaver on 
Windows:

�. Open Dreamweaver and make a copy of any 
page, such as index.htm or bio.htm, in the 
top level of your portfolio folder.

�. Call the new page running.htm and give it a 
title like “Jane Running.”

�. Delete the text and images (except the head-
ing and the accessibility test line) from the 
content div of the new running.htm page.

�. In Dreamweaver’s Code view, copy and paste 
the code from Figure 9.11 into the content div 
between the <p> tags following the <h1> tag, 
and before the accessibility line.

�. Back in the Design view, Click the  
(Plug-in) icon to select it. In the Properties 
panel, set the Src field to the URL of your 
movie. 

�. Also in the Properties panel, set the width 
(W) and height (H) of the run.avi movie to 
whatever you specified when you compressed 
it, adding 43 pixels to the height to acco-
modate the controller. So, if your run.avi is 
160x120, you would set W to 160 and H to 163.

�. Refresh the Assets panel if necessary, and 
verify that the run.wmv movie shows up in 
the  (Movies) section.

�0. Upload run.wmv to your server, then save 
running.htm and preview it in a browser.

<embed src=”http://www-rohan.sdsu.edu/~jdoe/template05/media/run.wmv” width=”160” 
height=”163” autostart=”1” showcontrols=”1” type=”application/x-mplayer2” pluginspage=”http://
www.microsoft.com/windows/windowsmedia/download/”> </embed>
Figure 9.�� Copy and paste this code for embedding a Windows Media Player (.wmv) file in an HTML page, 
changing the parameters shown in red. The movie must be on the web server before your movie page will work.

Figure 9.�0 running.htm in Split view showing where 
to insert the embed tag for run.wmv.

¸	Tip

n	The Play button in the Properties panel may 
give only an error message when you try to 
preview a .wmv file in Dreamweaver, but try 
previewing it in your browser and it should 
work fine.
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Adding a new CSS rule
When introducing a new element, such as this 
video, into your portfolio, you may find that you 
need a new CSS rule to position it the way you 
want. If so, here’s how.

To add a new CSS rule:

Be sure the portfolio.css file is checked out from 
your server and available for editing.

�. In Dreamweaver’s CSS Properties panel click 
the  (New CSS Rule) button.

�. In the New CSS Rule dialog (Figure 9.12) 
specify the Class Selector Type, give it a 
name (in our example, “imgfull”), and specify 
where you want to Define the rule. Click OK.

This latter is most important. Be sure to define 
it in portfolio.css, not in portfolio_print.css (it 
won’t apply unless they print the page) or This 
document only (it won’t be available to you in 
other pages in this site).

�. In the CSS Rule Definition dialog 
(Figure 9.13) select the rule categories you 
wish to specify and fill in the appropriate at-
tributes.

In our example, fill in only the Clear and Bottom 
and Left Margins fields in the Box category for 
the “imgfull” rule (as shown in Figure 9.13).

�. Click OK.

�. Switch to running.htm, select the plug-in 
icon, and select imgfull from the Class pop-
up menu in the Properties panel.

�. Save your page and preview in a browser.

Figure 9.�� Dreamweaver’s New CSS Rule dialog. Be 
sure to specify which document you wish to Define in.

Figure 9.�� Dreamweaver’s CSS Rule Definition Box 
dialog, with Clear and Margins specified.

¸	Tip

n	This example for adding a new CSS rule isn’t 
a particularly good one, because Dreamweaver 
doesn’t preview the resulting positioning very 
well. That makes previewing in a web brows-
er all the more important.
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anImatInG tHe WeB
Most people who grow up with television and 
movie cartoons know that animation consists of a 
series of still images flashed in rapid succession. 
Due to a physiological characteristic of our visual 
system called “persistence of vision,” we contin-
ue to “remember” the previous image as the new 
image appears. Our marvelous brains interpret 
similar images viewed this way as continuous,  
moving pictures.

From an instructional design point of view,  there 
are a number of ways to use motion pictures. 
There are many occasions when still images just 
don’t tell the whole story: demonstrating proce-
dures in which timing and motion are important; 
or describing cause-and-effect situations with 
multiple factors operating simultaneously.

Similarly, there are situations in which photo-
graphic movies are less optimal than animation. 
Photorealistic detail can interfere with identifying 
parts or characteristics, particularly for novices. 
Difficult-to-photograph processes such as the 
interior workings of an internal combustion en-
gine; or the workings of abstract concepts such as 
high and low pressure atmospheric systems, may 
work better as animation.

In this session of Homer, we’ll create a modest 
animation, one intended merely to give you a 
hands-on taste of several animation processes.
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How do we make animation?
From a production standpoint, there are a variety 
of methods you or your production staff can use 
to create animation. Traditional film animators 
draw and paint individual “cells” (so-called from 
the original celluloid medium) and photograph 
them, one at a time, with a movie camera. A small 
but thriving “claymation” community produces 
animation by posing miniature objects and mov-
ing and photographing them a frame at a time.

Computer animators use drawing and illustra-
tion programs to create multiple frames for 
animation. Others use 3D modeling and anima-
tion software. In this session, we’ll draw a few 
cells and then animate them in a simple graphics 
program. If you’d like to explore animation on 
your own, a good way to start is by animating 
stick figures or inanimate objects, or even digi-
tized photographs. Almost anything makes good 
material. From an animator’s’ perspective, “Why, 
then the world’s mine oyster.”

Figure �0.� This animation of  a canal barge moving 
through a lock is an example of  a situation in which 
photorealistic detail would probably have been an im-
pediment to learning the parts and processes involved.

Web animation

As usual, bandwidth provides the most 
important constraints to animation on the 
Web. As in film and video, animation is 
made of rapidly flashing multiple images 
on the screen, so you must take care to make 
each of those images as small as possible. As 
we build the animation in this session, we’ll 
point out some ways to do that.

There are several file formats for Web anima-
tion, including Macromedia’s Flash format. 
The oldest and perhaps most elegant method 
is GIF animation. It is a special variation of 
the GIF image format that automatically cy-
cles a series of GIFs, all contained in a single 
GIF file. Users don’t need a special plug-in to 
display animated GIFs in their browser. 
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The Concept
We’re going to make a simple Flash animation. 
(This tutorial uses Macromedia Flash version 8. 
If you have a different version, you may need to 
make some adjustments.) Flash is a very sweet 
graphics and animation tool that combines the 
best characteristics of both bitmap and vector 
graphics.

Without getting into too much detail about those 
terms, just know that bitmap graphics store every 
pixel, while vector graphics just store instructions 
for displaying pixels. To paraphrase the other 
Robin Williams, vector graphics feature “great 
big, complex images—teeny weeny living space.”

Flash capitalizes on this by letting you make vec-
tor animations. These do require a special Flash 
Player plug-in to play them back—but these days, 
most browsers come with Flash Player installed.

We’ll use Flash to get a first exposure to timelines, 
frames, frame animation, and tweening.

Figure �0.� The animation you’ll build in this tutorial, 
with rising sun, growing flower, and drifting clouds—all 
set to music!



�00

Session 10

Getting started in Flash
As always, make a backup of your current work 
so you have something to fall back on in case this 
current endeavor goes horribly wrong.

If you don’t have Macromedia Flash, download 
a 30 day trial version from http://www.adobe.
com/. Follow instructions to install the software.

To start a new animation file in Flash:

�. Open the Flash application.

�. Select the File > New… menu item and click 
on the General tab. Select Flash Document 
and click OK.

You will see a “Timeline” and under it a rect-
angular white “Stage” on a grey background 
(Figure 10.3).

�. Save your new file (in our example, save it as 
sunrise.fla in your offline folder).

To set the background color:

�. Select the Modify > Document… menu item.

�. Click on the Background color popup menu 
(Figure 10.4) and select a background color (in 
our example, you might use #��99FF).

�. Click OK.

Figure �0.� A new animation file in Macromedia Flash 
showing the default workspace layout with the toolbar 
at left, timeline at the top, and the blank stage at the 
bottom.

Looking around in Flash

One of the first things to do when starting to 
learn a new software application is to active-
ly survey it (Figure 10.3). Take a few minutes 
to look over the tool bar—run your mouse 
over each icon to see what it’s called. If 
you’re not sure what the words mean, select 
it and give it a try.

Pull down all the menus (MIST—the Menu 
Item Search Technique) just to see what’s 
there.

When you’re finished playing, close the file 
without saving it, and begin your actual 
project with a fresh file.
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Layers
Each element of a Flash movie should be placed 
in a separate timeline layer (a Flash layer is a like 
a Photoshop layer that goes through time). Your 
new movie file has a single layer to start with. 
We’ll be adding others as we go along. Naming 
each layer helps you keep track of the different 
elements as you develop your animation.

To rename a layer:

�. Double-click on the layer name (in our exam-
ple, Layer �).

�. Type the new name of the layer and press the 
Return or Enter key.

Painting
To paint the grass and hills in our picture, we’ll 
use the Rectangle and Paint Brush Tools.

To paint with the Rectangle Tool:

�. Select the  (Rectangle) Tool.

�. In the Properties palette select Fill and 
Stroke colors, set the Stroke height (to 4, in 
our example) and Stroke style (as shown in 
Figure 10.5).

�. On the stage, drag your cursor over the lower 
third (roughly) of your stage (Figure 10.6).

Figure �0.� Setting the Background color of  the stage 
in Flash’s Document Properties dialog.

Figure �0.� In the Rectangle Tool Properties palette, 
set the Stroke and Fill colors to shades of  green, the 
Stroke height to 4, and the Stroke style as shown.

Figure �0.� The stage with the rectangular grass area 
painted over the background color.
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To paint with the Brush Tool in Flash:

�. From the Toolbar select the  (Brush) 
Tool and set the Stroke and Fill colors to the 
color you’d like to paint the hills. To take ad-
vantage of atmospheric perspective, make the 
hills a little lighter than you made the grass 
(Figure 10.7).

�.  Under the Toolbar Options, select the 5th 
Brush Size from the top and the 3rd Brush 
Shape from the top (Figure 10.7).  

�. In the Properties palette, set the Smoothing 
to 80 (Figure �0.8). 

�.  With the Brush Tool, paint in hills, making 
sure to connect each one (Figure 10.9).  

�.  Select the  (Line) Tool to draw a line 
along the edge of the stage on the left and 
right sides of the hills to connect the top of 
each hill with the grass. This prevents the fill 
color we add in the next step from “leaking” 
out into the rest of the stage.

To paint with the Paint Bucket Tool:

�. Select the  (Paint Bucket) Tool.

�.  Fill the hills by clicking inside each one. It 
might look something like Figure 10.10.

Figure �0.9 Paint the outline of  the hills with the 
paintbrush tool. Be sure to use the Straight Line tool to 
paint lines along the edges of  the stage to contain the 
fill.

Figure �0.� Toolbar settings for the Brush tool.

Figure �0.8 Properties panel for the Brush Tool.

¸	Tips

n	Make everything you draw or paint in Flash 
into a Flash Symbol (see next page).

n	Put each Symbol or other element into a 
separate, named layer in the Timeline.
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To convert paintings to symbols:

A vital step to take with all your drawings and 
paintings is to convert them to Flash Symbols. 
Symbols are more stable, flexible, and useful.

1. In the Timeline, click in Frame � of the 
Background layer to select everything.

�. Select the Modify > Convert to Symbol… 
menu item. 

�. Enter a Name, select Movie clip, and click 
OK.

You can also make it a Button or Graphic, but 
Movie clip gives you the most flexibility.

Working with the Timeline
So far, we’ve been working in a single frame. 
Now we’re ready to add mutiple frames so we 
can animate. Even though this background won’t 
move, we must “paint” it across the background 
of all the frames that will have motion in them.

To add frames to a Timeline:

�.  In the Timeline, click in Frame 70 of the Back-
ground layer.

�.  Select the Insert >Timeline > Frame menu 
item.  This copies the same image from frame 
1 to frames 2 – 70 in the Background layer.

To lock a Layer:

It is easy to accidently change one layer when 
trying to edit a different one. To prevent this, 
keep all layers locked when not editing them.

�. In the Layer, click on the Lock button 
(Figure 10.12).

To unlock the layer to make it editable, simply 
click on the Lock button again.

Figure �0.�0 The hills filled.

Figure �0.�� The Convert to Symbol dialog box.

Figure �0.�� When you’re finished working in a layer, 
even temporarily, lock it so you won’t accidently modify 
it while trying to work in other layers.

¸	Tip

n	The following keyboard shortcuts may come 
in handy for Windows /Macintosh: 
• Cut: Ctrl-X / Cmnd-X 
• Copy: Ctrl-C / Cmnd-C 
• Paste in Place: Ctrl V / Cmnd-V 
• Undo: Ctrl-Z / Cmnd-Z
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Keyframe animation
There are several ways to create animations in 
Flash. We’ll start with a simple one, keyframe 
animation. You just draw successive frames in the 
Timeline and when you play them back, they 
appear to move.

To begin, remember, every time we add a new el-
ement to our animation, we put it in a new layer.

To create a new layer:

�.  Select the  (Insert Layer) button at the 
bottom left of the Timeline panel.

�.  Double-click the new Layer Name and type 
Flower.

�.  Make sure the Flower layer is above the 
Background layer (Figure 10.13) (drag it 
there if need be).

To insert a keyframe:

A keyframe is any frame in a layer that is differ-
ent from the frame before it. 

�.  In the Timeline, select frame 21 of the Flower 
layer.

�. Select the Insert > Timeline > Keyframe 
menu item.

Our flower will start growing in frame 21. At 12 
frames per second, that’ll be roughly 2 seconds 
into the animation.

Figure �0.�� A new layer called Flower above the 
locked Background layer.
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To paint animation in keyframes:

�.  From the toolbar select the  (Brush) 
Tool and select a green color for the stem and 
leaves. The second Brush Shape works well 
for this little sprout.

�.  Paint a short line from the grass toward 
the sky to form the beginning of the stem 
(Figure 10.14).

�. In the Timeline, select the next frame (in our 
example, frame 22 of the Flower layer) and 
select the Insert > Timeline > Keyframe 
menu item.

This makes an exact copy of the contents of the 
previous keyframe in the new keyframe. Now 
we’ll modify the new keyframe.

�.  Choose the  Selection Tool and place it 
over the top end of the green stem.  

You’ll notice a little  (“corner”) symbol appear 
next to the Selection arrow.  That indicates that 
you can change the position of just that end of the 
line without moving the entire line.  For example, 
you can “stretch” the line, which is what we’ll do.

�.  Click and drag the end of the line upward a 
little (Figure 10.15).

Repeat steps 3-6 several times up to frame 24 
in the Flower layer. Each time you do, you’ll be 
adding a new frame to the animation and modi-
fying the stem until you have a series of gradu-
ally changing frames.

Repeat step 3 for frames 25-40, but now use the 
Brush and Oval Tools, Paint Bucket Tool, and 
appropriate colors to add petals, leaves, and 
other parts to your flower, one at a time, until 
it looks something like Figure 10.16. Your stage 
should now look something like Figure 10.17.

Figure �0.�� The first sprout.

Figure �0.�� The sprout riseth up!

Figure �0.�� The flower blooms!

Figure �0.�� The flower blooms in the grass!
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Adding a soundtrack
Before we add more animation, let’s add 
some music, in the form of a file called 
music.wav. First, let’s inspect music.wav. 

Download music.wav from the course web site 
and inspect its properties as you did in Homer 9 
with run.mov or run.avi.

Notice that music.wav is uncompressed audio 
CD-quality sound, that is 16-bit stereo, 44kHz, 
and weighs in at around 5.5MB. You can play it 
in any music player on either Windows or Ma-
cintosh if you’d like to hear how that sounds, 
but your computer speakers may limit what you 
hear, unless you have a high end sound system 
attached.

44kHz just means that this file stores sound fre-
quencies up to 22kHz (44 divided by 2), which 
is about the limit of human hearing. 16-bit stor-
age means that each little chunk of recorded 
sound can hold one of about 65,000 variations 
in pitch and loudness, which is about as many 
as a human can distinguish. If you’re designing 
for aliens or insects, please see Homer Session 11. 
Stereo, of course, means two tracks.

Flash will compress all these parameters auto-
matically using the MP3 algorithm. It will dras-
tically reduce the size of the sound, to enable 
faster loading, but with minimal loss of quality. 
Very nice stuff. Let’s put music.wav into our 
sunrise.fla Flash document.

Previewing your Flash movie

At any point you can preview your Flash 
movie by selecting the Control > Test Mov-
ie menu item.

Are you remembering?

Of course, you’re saving your Flash anima-
tion file from time to time, and perhaps even 
backing it up at strategic moments? Mother 
would approve!
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Inserting sound in Flash

To insert sound into an animation:

�. Open the original sunrise.fla file in Flash.

�. Use the File > Import > Import To Li-
brary… menu item in Flash to import the 
music.wav file.

You’ll probably notice it on its way in, but if you 
can’t locate it after importing it, use the Window 
> Library menu item to inspect the contents of 
the Flash document Library.

�. Insert a new layer in your Flash Timeline and 
call it “Music.”

�. In the Timeline, select frame 1 of the Music 
layer.

�. In the Properties palette for frame 1 of the 
Music layer, select music.wav in the Sound 
pop-up menu (Figure 10.18).

�. Also in the Properties palette, select Stream 
from the Sync pop-up menu.

The sound file appears as a miniature wave form 
in the Music layer (Figure 10.19).

The sound will automatically take up as many 
frames as it uses in your animation, and with 
Stream selected, the sound will cut off at the end 
of the animation. 

The sound is just over 33 seconds long. You may 
recall that our sunrise movie runs at 12 frames 
per second (if you didn’t change it—and there’s 
no reason you would have). If you do the math, 
that’s about 390 frames. If you wish, you may 
extend the animation out to match the music, but 
it’s not necessary for our purposes.

Figure �0.�8 The Flash Properties palette for the first 
frame of  the Music layer.

Figure �0.�9 The Flash Timeline with the Music layer 
showing the wave form of  music.wav.
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Exporting as a Flash Movie
So far, we’ve been continuing to save this as a 
Flash Document (*.fla) file. Now we’re ready to 
export sunrise as a Flash Movie (*.swf) that can 
be played in a web browser.

To export your animation:

�.  Select File > Export Movie, and save your 
movie in your portfolio/media folder as a 
Flash Movie called sunrise.swf.

�.  Use the default settings in the Export Flash 
Player dialog box (Figure 10.20).

Notice that the default Export Flash Player  
uses the MP3 compression scheme for the sound 
at 16-bit mono. Taking the original two-channel 
stereo sound file and squeezing it into a single 
monaural channel alone cuts the file size in half. 
In fact, you’ll see that the MP3 compression has 
squeezed this sound way down.

Use the appropriate techniques to inspect the file 
size of the sunrise.swf movie. Ours is 24k (yours 
may differ somewhat). Remember that the sound 
itself started out as 5.5MB, and this is sound and 
animation. Flash really squeezes those files into 
small packages, and, as you’ll see, the music 
doesn’t sound half bad, even after compression.

To play your Movie:

�.  Double-click your sunrise.swf movie to open 
it in the Flash Player, or

�. Open a browser and use the File > Open 
menu item to find the sunrise.swf animation 
in your offline folder.

Does your flower grow? Try clicking Reload on 
your browser to see the flower grow and hear the 
music play again.

So, why sunrise?

You may be asking yourself why the heck 
we’re calling this animation “sunrise” when 
there’s no sun?

Yet!

Once you have your Flash animation inserted 
in an HTML page (see next page), you’re fin-
ished. Done. You can say goodbye to Homer. 
Bye!

But for those who might be interested in 
learning a little more Flash, keep going. 
You’ll learn another, even slicker method of 
animation using the demonstration movies 
on the course web site.

Figure �0.�0 The Flash Export Flash Player dialog box 
with default settings.
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Animating the Web

Inserting a Flash Movie in an 
HTML Page

�.  In Dreamweaver, use the  (Flash) and/or 

the  (Refresh Site List) buttons to list 
your sunrise.swf movie in the Assets panel.

�.  Make a copy of the HTML file running.htm 
in your portfolio folder and call the copy 
sunrise.htm.

�.  In the Design view, change the text in the 
Title field to read: Jane’s Sunrise.

�.  Still in the Design View, select the run.mov 
or run.avi element and press Delete or Back-
space on your keyboard to get rid of it.

File Management alert! Be sure you’re editing 
sunrise.htm and not running.htm.

�.  With your cursor still on the page in the 
content div, select sunrise.swf in the Assets 
panel and click the Insert button. 

�. In the Object Tag Accessibility Attributes 
dialog, type a description of the movie for the 
visually handicapped (Figure 10.21).

The sunrise.swf movie will appear on the page 
just where run.mov or run.avi was, only larger.

Dreamweaver automatically embeds the file with 
the correct code for playing Flash movies—you 
can see the relevant HTML if you Split the view.

�.  Save your work and preview it in a web 
browser.

8. Upload both sunrise.htm and sunrise.swf to 
the server and check them out on the web.

9. Add the sunrise.htm page to your menu. up-
date all your portfolio pages with the revised 
main menu tree.lbi, and check them back in.

Figure �0.�� The Flash Object Tag Accessibility Attri-
butes dialog box with the Title tag filled in.

Figure �0.�� The sunrise.htm page with the sunrise.
swf  movie embedded. You can preview a Flash movie in 
Dreamweaver by selecting it and clicking the Play but-
ton in the Properties panel.


